VirtualBox

Ticket #832 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

No DirectDraw with Matrox G550 DualHead (AGP) graphics card

Reported by: mathias.nyberg Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords: matrox, directdraw, g550
Cc: Guest type: other
Host type: other

Description

I have the Matrox G550 DualHead (AGP) graphics card in my computer. I run Ubuntu 7.10 and the latest version of Virtual Box, 1.5.2.

As guest OS i run my licensed Windows XP Pro SP2. Everything works fine except the graphics. Normal desktop using, surfing, MS Office and so on is no problem at all, but today i decided to install the old and famous Age of Empires II. No heavy, fancy graphics in my opinion, but no. No DirectDraw support. No 3D at all. (I've tried different startup-option refering to Microsoft's help-database-jada-jada).

I started dxdiag and it gave the same answer, no bouncing box inside another box = no DirectDraw.

What is the solution to this? I tried searching för "Matrox" in this forum and i got, guess what, zero ;-) I found an post ( http://www.virtualbox.org/ticket/618) concerning this (I think), but it was closed. Is there a solution to this problem?

Change History

comment:1 Changed 6 years ago by sandervl73

There is no 3d support, but basic 2d directdraw support is present. Did you forget to update the additions in the guest?

Your host graphics card is completely irrelevant in this case.

comment:2 Changed 6 years ago by mathias.nyberg

No, the Additions is installed and works perfectly. I cannot understand why DirectDraw won't work for me :-(

comment:3 Changed 6 years ago by sandervl73

Did you install the 1.5.2 additions or upgrade from a previous version?

comment:4 Changed 6 years ago by mathias.nyberg

The whole installation is a clean install, so everything is installed from scratch, no updates. Strange, isn't it?

comment:5 Changed 6 years ago by pcordes

I see the same thing. My host system is AMD64 Ubuntu Gutsy, on a Core 2 Duo (although I didn't enable VT-x in vbox). I'm using Ubuntu's virtualbox package, 1.5.0-dfsg2-1ubuntu3. (Hmmm, I didn't realize I didn't have 1.5.2 until just now).

To reproduce the problem, create a vm and install windows 2000 or winxp (I've tried with win2k pro, win2k sp4 pro, and winxp sp2 pro). Install the guest additions (VBoxGuestAdditions_1.5.0_OSE.iso).

Run dxdiag, and test direct draw. The tests all fail until you turn down the video accel in the windows control panel to a level that disables all directdraw acceleration.

Sorry if this is already fixed in 1.5.2. I thought that's what I was using, and I know there are directdraw fixes in the changelog. I'll go test...

BTW, what I really wanted was to play Starship Titanic, which I haven't gotten to work except in win98 on real hardware. (or unplayably slowly in qemu with its Cirrus vid card. neither kqemu nor kvm work with win98, and I haven't got the game to work in win2k/xp.) The lack of guest additions for win98 make vbox unusable for what I wanted, since Starship Titanic needs 640x480/16bpp. It also needs hardware accel to work: it's log shows errors when I tried it on vbox winxp with directx accel turned down to the point where dxdiag passes.

comment:6 Changed 6 years ago by pcordes

I upgraded to vbox 1.5.2 (from the binary-only Ubuntu repository, not the open-source version, because the debian sources for 1.5.2 wouldn't compile on my AMD64 Ubuntu system.). Now all dxdiag's directdraw tests pass even with hardware accel at the max. (I upgraded the guest additions first). I tried dxdiag under win2ksp4 and winxp sp2.

Starship Titanic runs under winxp (although the audio stutters and vbox uses 100%CPU. Maybe it would do better if I was running a 16bpp X server.)

original submitter: Are you sure you have vbox 1.5.2, since virtualbox-ose packaged by Ubuntu is version 1.5.0 in Gutsy. I made that mistake myself.

devs: congrats on fixing the bugs.

comment:7 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Presumably the original poster was using 1.5.0. If not, reopen please.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use