VirtualBox

Ticket #8255 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VirtualBox v4.0.2 segfaults on Linux host while running VS2005 within a Windows XP Pro SP3 session

Reported by: dinosaur Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords: VBoxREM32.so segfault
Cc: Guest type: Windows
Host type: Linux

Description

So, far I was running VirtualBox v3 happily, and recently updated to v4.0.2. Today, I started a Windows XP Pro SP3 session to compile a large C++ program under VS2005 and at some point during the compilation, VirtualBox segfaults with the following message reported in /var/log/messages:

First attempt:

Feb  3 12:43:58 localhost klogd: VirtualBox[2525]: segfault at 99655dcc ip b148bda0 sp b22ca000 error 6 in VBoxREM32.so[b145c000+7d000]

Second attempt:

Feb  3 14:03:22 localhost klogd: VirtualBox[6806]: segfault at 78e79c30 ip b141eda0 sp b21ca000 error 6 in VBoxREM32.so[b13ef000+7d000]

I cannot provide a core dump since they are disabled in my kernel.

I went back to v3.0.12 so that I compile my program...

Attachments

VBox.log Download (48.6 KB) - added by dinosaur 3 years ago.

Change History

Changed 3 years ago by dinosaur

comment:1 follow-up: ↓ 2 Changed 3 years ago by frank

Without a core dump this crash is difficult to analyze. You might be  able to activate core dumps on your host.

comment:2 in reply to: ↑ 1 Changed 3 years ago by dinosaur

Replying to frank:

Without a core dump this crash is difficult to analyze. You might be  able to activate core dumps on your host.

No, sorry, my kernel is purposely configured without coredumps support and I have no time to fiddle with this. I went back to VirtualBox v3.2.12 anyway, and will not loose my time again with v4 before it has stabilized enough...

comment:3 Changed 3 years ago by frank

  • Priority changed from blocker to major

comment:4 Changed 3 years ago by frank

We probably fixed the bug you observed. Could you verify by installing  this test build?

comment:5 Changed 3 years ago by frank

Please check if VBox 4.0.4 fixes your problem.

comment:6 Changed 3 years ago by dinosaur

I installed and tested v4.0.4 today, and could not reproduce the bug that was happening in v4.0.2 in the exact same conditions.

I guess this bug can be considered fixed in v4.0.4.

Thank you.

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use