VirtualBox

Ticket #8253 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Importing Pre-built VM for SOA amd BPM Suite 11g fails

Reported by: vitali Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords: import virtual machine fails medium cannot closed still attached
Cc: Guest type: other
Host type: other

Description

Exactly followed the instructions at the link below to setup the "Pre-built Virtual Machine for SOA Suite and BPM Suite 11g":  http://www.oracle.com/technetwork/middleware/soasuite/learnmore/vmsoa-172279.html

VirtualBox was successfully installed. Checked every downloaded VM image file with the md5sums utility, so the files are positively not corrupted. When running import of the ovf file (i.e. vbox-oel5u4-soabpm-11gr1ps2-bp1-otn.ovf), it runs for a few minutes, the progress bar briefly flashes 100% and then a popup error window is shown; the error messages reads: Failed to import applience <here-goes-pathname>\vbox-oel5u4-soabpm-11gr1ps2-bp1-otn.ovf.

Medium 'C:\VirtualBox VMs\vbox-oel5u4-soabpm-11gr1ps2-bp1-otn_1\vbox-oel5u4-soabpm-11gr1ps2bp1-root.vmdk' cannot be closed because it is still attached to 1 virtual machine.

Details: Result Code: VBOX_E_OBJECT_IN_USE (0x80BB000C) Component: Medium Interface: IMedium (9edda847-1279-4b0a-9af7-9d66251ccc18}

I also noted that during the import, the vbox-oel5u4-soabpm-11gr1ps2bp1-root.vmdk gets created in the specified Default Machine Folder and remains even after the error window is closed and the import operation cancelled. However, the 2nd file, vbox-oel5u4-soabpm-11gr1ps2bp1-oracle.vmdk, gets created and a second later after the error message pops up, it gets deleted.

Please see the attached screenshot showing the error messages. Unfortunately I was not able to locate VBox.log file. If you provide me where it might be located on a Windows 7 machine, I'll try to find it again.

I later found that the IMedium interface is defined in VirtualBox.xidl file. The error probably originates from the HRESULT Medium::close(GuidList *pllRegistriesThatNeedSaving, AutoCaller &autoCaller) method in the MediumImpl.cpp file.

Please let me know if I can be of any other assistance. Regards, Vitali Tchalov

Attachments

vm-import-fail-cannot-close-medium.PNG Download (134.1 KB) - added by vitali 3 years ago.
ovf_import.png Download (140.1 KB) - added by digiwhite 3 years ago.
Import dialog
ovf_import_error.png Download (136.4 KB) - added by digiwhite 3 years ago.
Error as import result
OSOA_vbox_error.gif Download (61.3 KB) - added by donzur 3 years ago.

Change History

Changed 3 years ago by vitali

comment:1 Changed 3 years ago by digiwhite

I have tried to import virtual machine from OVF format (VM has been exported from VirtualBox 3.2.12, Arch Linux, I sorry, but I forgot kernel version number) on Linux (VirtualBox 4.0.2 r69518, kernel version 2.6.37). So as result I have got the same error as ticket starter, Vitali.

Please find some screenshots attached.

Thansk, Dmitry.

Changed 3 years ago by digiwhite

Import dialog

Changed 3 years ago by digiwhite

Error as import result

comment:2 Changed 3 years ago by donzur

Does not work for me either.

Changed 3 years ago by donzur

comment:3 Changed 3 years ago by digiwhite

As I can see this error occurs when to VM connected two (may be more) virtual hard disk drives. I think if try to import VM with one virtual hdd all will be correct.

comment:4 Changed 3 years ago by Brians

Is there a solution to this issue yet? I spent days trying to resolve this problem.

comment:5 Changed 3 years ago by joost

Same problem here. If you need a workaround: use version 3.2 of virtualbox....

comment:6 Changed 3 years ago by klaus

Finally figured out the cause - it's a broken OVF file. VirtualBox up to version 3.2.8 had a bug which resulted in inconsistent OVF files if more than one disk was attached to a VM.

Quick "workaround":  http://blogs.sun.com/fatbloke/entry/errors_when_importing_ovf_appliances

comment:7 Changed 3 years ago by klaus

The claims in comments above that the VM was exported with VirtualBox 3.2.12 doesn't make sense. The bug causing the corrupted OVF files (only when more than one disk was attached) was fixed in 3.2.10.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 in reply to: ↑ description Changed 3 years ago by tony.watson@…

Replying to vitali:

Exactly followed the instructions at the link below to setup the "Pre-built Virtual Machine for SOA Suite and BPM Suite 11g":  http://www.oracle.com/technetwork/middleware/soasuite/learnmore/vmsoa-172279.html

VirtualBox was successfully installed. Checked every downloaded VM image file with the md5sums utility, so the files are positively not corrupted. When running import of the ovf file (i.e. vbox-oel5u4-soabpm-11gr1ps2-bp1-otn.ovf), it runs for a few minutes, the progress bar briefly flashes 100% and then a popup error window is shown; the error messages reads: Failed to import applience <here-goes-pathname>\vbox-oel5u4-soabpm-11gr1ps2-bp1-otn.ovf.

Medium 'C:\VirtualBox VMs\vbox-oel5u4-soabpm-11gr1ps2-bp1-otn_1\vbox-oel5u4-soabpm-11gr1ps2bp1-root.vmdk' cannot be closed because it is still attached to 1 virtual machine.

Details: Result Code: VBOX_E_OBJECT_IN_USE (0x80BB000C) Component: Medium Interface: IMedium (9edda847-1279-4b0a-9af7-9d66251ccc18}

I also noted that during the import, the vbox-oel5u4-soabpm-11gr1ps2bp1-root.vmdk gets created in the specified Default Machine Folder and remains even after the error window is closed and the import operation cancelled. However, the 2nd file, vbox-oel5u4-soabpm-11gr1ps2bp1-oracle.vmdk, gets created and a second later after the error message pops up, it gets deleted.

Please see the attached screenshot showing the error messages. Unfortunately I was not able to locate VBox.log file. If you provide me where it might be located on a Windows 7 machine, I'll try to find it again.

I later found that the IMedium interface is defined in VirtualBox.xidl file. The error probably originates from the HRESULT Medium::close(GuidList *pllRegistriesThatNeedSaving, AutoCaller &autoCaller) method in the MediumImpl.cpp file.

Please let me know if I can be of any other assistance. Regards, Vitali Tchalov

Folks - I can see this ticket is fixed/closed but I am not quite sure what the fix actually is. I have VB 4.0.6 and have exactly the same issue with another of the pre-built VMs from oracale Tech ( http://www.oracle.com/technetwork/middleware/weblogic/downloads/weblogic-developer-vm-303434.html)

Would be keen to know what the actual fix/workaround is.

Thanks TW

comment:10 Changed 3 years ago by efierro

I ran into the same problem moving a VM from a Linux host to a Windows 7 host machine... just fixed it removing the SharedFolders entries from my virtual box definition file (.vbox), removed everything between

<SharedFolders
...
...
SharedFolders/>

I had some host folders shared to the vm using the Linux path. After doing that I was able to just add the vm to vbox. The error message is not specific to this situation but this is definitely one of the causes of this error. I hope it helps.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use