VirtualBox

Ticket #8221 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

BLKCACHE_IOERR after creating snapshots. => fixed in svn/4.0.4

Reported by: jptech Owned by:
Priority: minor Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I get a BLKCACHE_IOERR after creating a 2nd snapshot on one of my VMs. It causes the VM to switch into suspended state when trying to boot the guest. Others have reported a similar problem here:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=38523

Some things that may be relevant:

  • The VM was imported from an appliance that I created (VMDK disk)
  • Everything works ok if I enable Use host I/O cache on my VM
  • I'm using an AHCI SATA controller in my VM.

I experience this problem by doing the following:

  • create a minimal guest installation
  • export the guest as an appliance
  • import the appliance as a new VM
  • work on guest
  • stop guest
  • snapshot 1
  • start guest
  • work on guest
  • stop guest
  • snapshot 2
  • error starting guest

I'm using a Windows 7 64bit host and an Ubuntu 10.04.1 (i386) guest. All of my virtual machine disk files are writable and I have >150GB free on the (host) disk.

Attachments

VBox.log Download (42.4 KB) - added by jptech 3 years ago.

Change History

Changed 3 years ago by jptech

comment:1 Changed 3 years ago by aeichner

  • Summary changed from BLKCACHE_IOERR after creating snapshots. to BLKCACHE_IOERR after creating snapshots. => fixed in svn/4.0.4

Thanks for the report. The bug will be fixed in the next maintenance release.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 3 years ago by frank

Still reproducible with VBox 4.0.12?

comment:5 Changed 3 years ago by christoph

I have tested with version 4.0.12 and the same Windows 7 32-bit install with an active snapshot for several hours now, generating heavy I/O load via some reinstalls and file copy. Not a single error, neither during boot nor when machine is running. So issue is not reproducible and seems to be resolved. Thanks, all the best

christoph

P.S.: Do you have an option (or know one who has) to change the user name in my recent post from 2011-03-16. I mistakenly entered my eMail as user name. Thanks in advance.

comment:6 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Sorry, such an option is not available. I could only remove these two comments. AS the bug seems now to be fixed for you that's probably not a problem. Give me a note.

comment:7 Changed 3 years ago by christoph

If it does not render this entry unreadable, I would appreciate that. In any case you (or me) could probably repost my entry, immediately marked as fixed. Thanks for your help, and sorry for causing trouble.

comment:8 Changed 3 years ago by frank

Done.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use