VirtualBox

Ticket #8213 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

VBoxManage modifyhd <filename> --immutable failure

Reported by: Perryg Owned by:
Priority: major Component: VM control
Version: VirtualBox 4.0.2 Keywords: VBoxManage modifyhd
Cc: Guest type: Linux
Host type: Linux

Description

I cloned (using VBox clonehd) three different formats of a working VM. Clone went smooth and created (1) *.vdi, (2) *.vhd, and (3) *.vmdk.

Next I tried to set the three to immutable using VBoxManage modifyhd <machine name> --type immutable.

All three returned the same error.

VBoxManage: error: Details: code VBOX_E_OBJECT_NOT_FOUND (0x80bb0001), component VirtualBox, interface IVirtualBox, callee nsISupports
Context: "FindMedium(Bstr(pszFilenameOrUuid).raw(), enmDevType, pMedium.asOutParam())" at line 174 of file VBoxManageDisk.cpp

According to the help section I should be able to do this, but can't. I am attaching a text file of the process. I went so far as typing the absolute path as well, but that made no difference. I also tried the UUID but still nothing. The reason I am doing this is I had a user ask for help because they could not get it to work. Not something I do everyday. So where did I go wrong, or is something broken?

Attachments

modifyhd-immutable.txt Download (3.1 KB) - added by Perryg 3 years ago.

Change History

Changed 3 years ago by Perryg

comment:1 Changed 3 years ago by cendaaro

This is essentially the same issue as ticket #8105 (see description for a workaround):

 http://www.virtualbox.org/ticket/8105

This ticket should be marked as a duplicate.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Correct.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use