VirtualBox

Ticket #8208 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

Deletion of virtual machines fails

Reported by: ebonweaver Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

If you try to delete a virtual machine, it is removed from the list in the Manager but you get an error that it failed to remove the virtual machine. If you then look in your home virtualbox vms folder you will still see the folder for the VM you tried to delete and all it's vdi and other files. You can manually delete that folder just fine.

Attachments

deletefail.png Download (25.3 KB) - added by ebonweaver 3 years ago.

Change History

comment:1 Changed 3 years ago by frank

Can't reproduce. What did you do exactly? When you clicked on Delete VM, did you select Remove only or Delete all files? I assume the latter. Actually what you describe sounds like some permission problem. Did you create the VM as administrator and tried it to remove as normal user or something like that?

comment:2 Changed 3 years ago by ebonweaver

You assume correct as if I was only deleting the VM and not the files there would be no error and bug report of the file deletion failing. However, if it was a permissions issue then I wouldn't have been able to delete the files manually with no issue as I mentioned I did. Also, running as admin would make the VM in the admin's home, not the user's home. The VM was created and then attempted to be deleted under the same account moments later as it was only a test of the creation process. I can reproduce this 100% of the time. I will attach a screenshot of the error box.

Changed 3 years ago by ebonweaver

comment:3 Changed 3 years ago by frank

Aha, that looks like the VBoxSVC daemon crashes for some reason. Where did you store your VM settings (which path on your host)? Are the settings stored on an external medium or does the path contain any special characters?

comment:4 Changed 3 years ago by ebonweaver

nope, nothing fancy. I'm not going into the settings after creation so there is no ISO or shared folder or anything else. I'm not importing or using an existing vdi. I'm just clicking new and not even changing anything in the wizard, just making a new VM with new VHD with all the default settings. This is a straight out of the box experience. As you can see from the screenshot, the name of the vm is test so there are no special characters in that, and the path is the default in the user home folder which again does not have any special characters as windows would not allow that. All letters, no spaces, no expernal devices, nothing.

comment:5 Changed 3 years ago by frank

Just read the bug report of another (french) user who wrote that his account name has some special (french) characters so having a special path is indeed possible. Still trying to find out how your platform differs from mine because I cannot reproduce this problem. And this is the first such bug report I saw, I expect much more reports if that function would be buggy in general.

comment:6 Changed 3 years ago by ebonweaver

Interesting, I was certain windows disallowed special characters in the user name, but maybe there are some that are allowed, especially non-english letters, or win 7 is more flexible and I hadn't noticed. I would however expect that any character that Explorer can deal with navigating file structure would be ok by VirtualBox as well. Still, not the case in this instance. I will try on Mac later today to see how it behaves as well. The only other tidbits I can offer which do not seem relevant to me are the machine is bound to AD and I'm logged in as a network user. It is 64 bit Win 7. I did install VirtualBox under the user account using network admin credentials, but I see no other indications of any permission issues this might have caused, nor is there a permissions issue on the files it creates for the VM which it then fails to delete as mentioned.

comment:7 Changed 3 years ago by ebonweaver

I have confirmed there is no issue on the Mac client, so it's not a cross platform issue in the code, it's only on Windows, at least as I have speced above.

comment:8 Changed 3 years ago by frank

Reproduced on Windows 7, works on Vista.

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Actually a duplicate of #8005.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use