VirtualBox

Ticket #8178 (closed defect: duplicate)

Opened 3 years ago

Last modified 2 years ago

Guru Meditation (VERR_ACCESS_DENIED) with VirtualBox >= 3.2.0 on the same disk ops

Reported by: VitRom Owned by:
Priority: major Component: VMM/RAW
Version: VirtualBox 3.2.0 Keywords:
Cc: Guest type: BSD
Host type: Windows

Description (last modified by frank) (diff)

Well, the best case description is "bying Sun VB by Oracle" but it's a very complex system bug ;) so let's concentrate on an accessible details:

All VB bulds after the lastest Sun build (3.1.8) have exacltly the same buggy behaviour with a FreeBSD-7-based pfSense 1.2.3 -- the VM dies on start of the disk partitioning.

Steps 2 re:

  1. get and extract a current stable install (pfSense-1.2.3-RELEASE-LiveCD-Installer.iso.gz) iso of pfSense from  http://www.pfsense.org/mirror.php?section=downloads
  1. Make a quick defaulted VM with a maximum of defaults, with a 1Gb expandable disk and downloaded iso as cdrom.
  1. Boot VM, press Enter (default boot) then I (installer mode)
  1. On installer screen choose "Accept this" and then "Quick/Easy" and proceed
  1. VM died

This happens regardless of any storage-related VM settings like an adapter caching or p3/p4 controller type or anything else on an all releases after a Suns lastest.


Host: WinXP SP3+
Guest: pfSense 1.2.3 == FreeBSD-7 with some patches
Hardware: Any x86

Attachments

pfSense-2011-01-24-21-48-52.zip Download (26.7 KB) - added by VitRom 3 years ago.
pfSense-2011-01-24-21-48-52.log Download (173.8 KB) - added by VitRom 3 years ago.

Change History

Changed 3 years ago by VitRom

Changed 3 years ago by VitRom

comment:1 follow-up: ↓ 3 Changed 3 years ago by frank

  • Component changed from virtual disk to VMM/RAW
  • Summary changed from ALL Oracle-built VirtualBoxes dies on the same disk ops to Guru Meditation (VERR_ACCESS_DENIED) with VirtualBox >= 3.2.0 on the same disk ops

Looks more like an issue with the software virtualization.

comment:2 Changed 3 years ago by frank

  • Priority changed from critical to major

comment:3 in reply to: ↑ 1 Changed 3 years ago by VitRom

Replying to frank:

Looks more like an issue with the software virtualization.

Looks right -- found a VT-capable CPU (P DualCore E5300) and tried to repro on the same "default" (in this case with VT-x and Nested Paging enabled) VM with "no succes": install finished OK

comment:4 Changed 2 years ago by VitRom

Well, so what? No any movements nor even any manual and/or system requirements corrections?

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
  • Description modified (diff)

Actually we were able to reproduce this problem now and we want to make it working even for non-VT-x CPUs. Marking this one as duplicate of #7589 (same problem).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use