VirtualBox

Ticket #8146 (reopened defect)

Opened 3 years ago

Last modified 3 weeks ago

Windows XP crashed after a while in Version 4.0.2 => Fixed in 4.0.4

Reported by: john.doe Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I was not in front of my PC, so the only think I could say is that a Windows XP guest that run for one or two hours crashed unexpected. The log is added.

Attachments

Windows XP-2011-01-21-15-57-11.log Download (58.8 KB) - added by john.doe 3 years ago.
the log of a windows xp crash
Windows XP-2011-01-23-13-36-36.log Download (61.0 KB) - added by john.doe 3 years ago.
Could be the same crash two days later
relogfiles.zip Download (43.6 KB) - added by Flancer 3 years ago.
Windows XP-2011-01-27-23-44-34.log Download (67.0 KB) - added by john.doe 3 years ago.
Happends on another machine (AMD)
VBox.log.1 Download (64.3 KB) - added by Flancer 3 years ago.

Change History

Changed 3 years ago by john.doe

the log of a windows xp crash

Changed 3 years ago by john.doe

Could be the same crash two days later

Changed 3 years ago by Flancer

comment:1 Changed 3 years ago by Flancer

I experienced the same problems. Happened rather quickly sometimes. Downgrading to 3.2.12 made things work again.

comment:2 Changed 3 years ago by frank

Sounds like a duplicate of #8008. Please could you try the VBoxManage settings posted there and check if it helps? Make sure to power-down your VM before doing VBoxManage setextradata ...

Changed 3 years ago by john.doe

Happends on another machine (AMD)

comment:3 Changed 3 years ago by Flancer

Ok will try after the 10th of February.

comment:4 follow-up: ↓ 5 Changed 3 years ago by frank

john.doe, in your case S4 was entered. Apparently you did not

VBoxManage setextradata VM_NAME \
  VBoxInternal/Devices/acpi/0/Config/ PowerS4Enabled 0

comment:5 in reply to: ↑ 4 Changed 3 years ago by john.doe

Replying to frank:

john.doe, in your case S4 was entered. Apparently you did not

VBoxManage setextradata VM_NAME \
  VBoxInternal/Devices/acpi/0/Config/ PowerS4Enabled 0

I did it(hope so): Here is the terminal output. If trieed it two times. The second one with a less withespace in VBoxInternal/Devices/acpi/0/Config/ PowerS4Enabled 0

Seems to work, because of no feedback from the console.

Could I please get feedback if it is correct? And what now? Starting the machine, waiting until it crashes and file the log?

user@linux-3zjc:~> VBoxManage setextradata 'Windows XP' \

VBoxInternal/Devices/acpi/0/Config/ PowerS4Enabled 0

Oracle VM VirtualBox Command Line Management Interface Version 4.0.2_OSE (C) 2005-2011 Oracle Corporation All rights reserved.

Usage:

VBoxManage setextradata global|<uuid>|<name>

<key> [<value>] (no value deletes key)

Syntax error: Too many parameters user@linux-3zjc:~> VBoxManage setextradata 'Windows XP' \

VBoxInternal/Devices/acpi/0/Config/PowerS4Enabled 0

user@linux-3zjc:~>

comment:6 Changed 3 years ago by john.doe

O.k I´ve read #8008. I´ve also done VBoxManage setextradata 'Windows XP' \

VBoxInternal/Devices/acpi/0/Config/PowerS1Enabled 0

Also with no return from the console.

comment:7 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Doing these commands you change a hidden VM setting permanently. Getting no feedback is correct. I will close this ticket as duplicate of the tickets #8008 and #8126.

comment:8 Changed 3 years ago by Flancer

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I tried the steps you had mentioned but didn't work.

Changed 3 years ago by Flancer

comment:9 Changed 3 years ago by frank

Ok, in that case it is still a duplicate and it will be fixed in the next maintenance release. Your log clearly shows that the guest tried to enter S1, which was not allowed, then it tried to enter S4, which was not allowed either and then the guest decided to enter S5. The reason for this strange behavior is that VBox 4.0 and VBox 4.0.2 announce that the guest is allowed to switch into the ACPI states S1 and S4. The commands you tried from #8008 make the VMM ignore the requests for entering S1 and S4, and then it decides to enter S5.

The next maintenance release will not announce S1 and S4 to be available anymore, so the old behavior of 3.2.12 will be restored.

comment:10 Changed 3 years ago by frank

  • Summary changed from Windows XP crashed after a while in Version 4.0.2 to Windows XP crashed after a while in Version 4.0.2 => Fixed in 4.0.4

comment:11 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed in 4.0.4

comment:12 Changed 3 weeks ago by khh

  • Status changed from closed to reopened
  • Resolution fixed deleted

This bug is back in the latest release (still WinXP SP3). As before running the below commands fixes it.

VBoxManage setextradata VM_NAME VBoxInternal/Devices/acpi/0/Config/ PowerS4Enabled 0
VBoxManage setextradata VM_NAME VBoxInternal/Devices/acpi/0/Config/ PowerS1Enabled 0
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use