VirtualBox

Ticket #8131 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

Window 7 guest keeps aborting => Fixed in SVN

Reported by: ranamalo Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

My host: 64 bit 10.04 ubnutu Intel Core i7 Q 740 1.73GHz 6GB RAM

My guest: 32 bit windows 7 1 cpu 1 GB RAM

VirtualBox version 4.0.0 r69151

The guest will be running fine and then I'll notice that it aborted. I am not able to currently connect any certain action to the aborts. The logs don't seem to show any problems. I have uploaded a core dump for you to analyze. Please let me know if you need any further info.

Change History

comment:1 Changed 3 years ago by frank

  • Cc frank.mehnert@… removed

comment:2 Changed 3 years ago by md2017

I have the same issue with 4.0.2 running on Mac OS X 10.6.5 host, with Windows 7 guest. I just notice (several times a day) that the guest has quit.

comment:3 Changed 3 years ago by frank

ranamalo, did upgrading to 4.0.2 help?

md2017, could your problem a duplicate of #8008?

comment:4 Changed 3 years ago by ranamalo

I run compiz with the cube. I noticed that most of the time the aborts occurred (with version 4.0.0) when I was trying to switch workspaces (with ctrl alt left or right arrow) from the workspace where the win 7 vm was running. It's strange depending on which window is selected it it would work (to change workspaces) sometimes and sometimes it wouldn't . But it appears that upgrading to 4.0.2 has indeed helped. It has not aborted once since I upgraded.

comment:5 Changed 3 years ago by ranamalo

I take that back. It has aborted twice today already. It definitely has to do with going to a different workspace via compiz, although it may not be limited to compiz. Today I had a blinking minimized download window from firefox. I was on the workspace of the win 7 vm. I could see the blinking window (which was located on a different workspace but it shows up minimized on all workspaces blinking to notify you) from the win 7 workspace. I clicked on it and it brought me to the workspace where the firefox download had completed and the win 7 vm aborted.

comment:6 Changed 3 years ago by frank

Please could you try the following:

VBoxManage setextradata VM_NAME \
  VBoxInternal/Devices/acpi/0/Config/ PowerS1Enabled 0

VBoxManage setextradata VM_NAME \
  VBoxInternal/Devices/acpi/0/Config/ PowerS4Enabled 0

-- replace VM_NAME by the name of that VM and make sure the VM is power off when you do this. Does this change anything?

comment:7 Changed 3 years ago by frank

  • Summary changed from Window 7 guest keeps aborting to Window 7 guest keeps aborting => Fixed in SVN

We think that we actually found the cases for your crashes. The fix will be part of the next maintenance release.

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use