VirtualBox

Ticket #800 (closed defect: worksforme)

Opened 7 years ago

Last modified 5 years ago

Network regression (Linux host, W2003 Server guest)

Reported by: ugemkow Owned by:
Priority: major Component: network
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: other
Host type: other

Description

When upgrading from 1.5.0 to 1.5.2, networking no longer works in our configuration. Going back to 1.5.0 solved the problem.

The guest (Windows 2003 server) was not able to send packets, it seemed it was able to receive packets.

Attachments

vm3.xml Download (2.6 KB) - added by ugemkow 7 years ago.
Machine description file
VBox.log.1 Download (31.2 KB) - added by ugemkow 7 years ago.
Log file

Change History

Changed 7 years ago by ugemkow

Machine description file

Changed 7 years ago by ugemkow

Log file

comment:1 follow-up: ↓ 2 Changed 7 years ago by Lelik

According to your VM configuration you should have already created and configured (and accessible by user) 'tapv3' interface on the host, correct?

Tried same configuration, works fine.

comment:2 in reply to: ↑ 1 Changed 7 years ago by ugemkow

Replying to Lelik:

According to your VM configuration you should have already created and configured (and accessible by user) 'tapv3' interface on the host, correct?

This is correct. All is done by scripts which also start the VM. These scripts are unmodified between 1.5.0 and 1.5.2 and run automatically, so I am pretty sure that the same configuration is used with 1.5.0 and 1.5.2.

Tried same configuration, works fine.

Our configuration is a little bit special as it uses routing (not bridging). I will try to debug a little bit and get more insight in the problem and come back to this (have to wait for the weekend, it is a production system)

Thanks so far

comment:3 Changed 6 years ago by ugemkow

I now checked once again carefully and the problem remains:

When starting my vm with 1.5.0, all works fine, the guest is reachable through the network. When updating to 1.5.2 and performing exactly the same steps as with 1.5.0 (I am sure - this is completely script based) the guest is not reachable.

We use a somehow unusual networking config (routed)

Unfortunately it is rather difficult for me to debug this, this is a production system which I can stop only for short periods of time.

comment:4 Changed 6 years ago by frank

There is a regression in 1.5.2 where network send did stop after a snapshot was created. Could this be your issue, that is, are you working with snapshots?

comment:5 Changed 6 years ago by ugemkow

Thanks for the answer. Unfortunately I do not use snapshots, so this is not the problem.

comment:6 Changed 6 years ago by frank

Could you retry with version 1.5.4 anyway?

comment:7 Changed 6 years ago by ugemkow

I tried with 1.5.4 and unfortunately the regression remains.

comment:8 Changed 6 years ago by ugemkow

The same regression remains in 1.5.6 (and also the reported problem that reverting to an older version of vbox in the same release does not work because of changes in the xml-description file)

comment:9 Changed 6 years ago by frank

  • Component changed from other to network

comment:10 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Retry with a 2.1.2 and reopen if required please.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use