VirtualBox

Ticket #7997 (closed defect: invalid)

Opened 3 years ago

Last modified 3 years ago

VBoxManage createhd no longer supports shareable disks

Reported by: hqstevenson Owned by:
Priority: major Component: other
Version: VirtualBox 4.0.0 Keywords: VBoxManage createhd shareable
Cc: Guest type: Linux
Host type: Windows

Description

With the 4.0 upgrade, the VBoxManage createhd command no longer allows the direct creation of shareable disks (the --type parameter is no longer recognized).

The only workaround I've found so far is to create the disk without the --type parameter, and then use VBoxManager modifyhd to change the type.

Also, the --remember parameter is not recognized in v4.0.

Is this by design, or a regression?

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

This command is only for creating a hard disk. To select the mode you have to use the storageattach command to attach the image to a dedicated storage controller. As long as the medium is not attached there is no need to specify the type.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use