VirtualBox

Ticket #7986 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

VirtualBox 4.0.0: Screen destroyed after CDShell/bcdw menu => Fixed in SVN

Reported by: Hubert Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.0 Keywords: CDShell, bcdw, CD menu, WinPE, scrambled screen
Cc: Guest type: Windows
Host type: Windows

Description

I am booting a CD ISO image consisting of a CDShell/bcdw choice to boot following operating systems (all 32bit): 1) Windows PE (XP Professional) 2) Linux (DSL)

The CD menu is built with bcdw (2.01a) commands: 'SetTextVideoMode' and 'SetGraphicsVideoMode 800 600'

Following difficulty arises in VirtualBox 4.0.0 - all versions 2.x/3.x I have tested so far do not show this difficulty (including 3.2.10 and 3.2.12):

When the operating system is booted after the CDShell/bcdw choice about 2/3 of the lower part of the VirtualBox screen is scrambled (it seems to be a memory part of the previous shown graphics in the boot screen) and this lower part is not used to show the output of the operating system - the 1/3 part of the upper part of the screen is used to show the output of the operating system only. And, 2/3 of the output is missing and the operating system cannot be operated correctly (no scrolling is possible). This behaviour takes place when booting the WinPE or the Linux system after the CDShell/bcdw boot menu - the cause seems to be the CD menu. In the VirtualBox 4.0.0 history a change to the virtual BIOS is stated: Reduced stack size. Maybe this has a bad influence here.

My host operating system is Windows XP SP03 32bit.

Attachments

Screenshots.zip Download (122.1 KB) - added by Hubert 3 years ago.
Screenshots
VBox.log Download (65.7 KB) - added by Hubert 3 years ago.
Logfile VirtualBox

Change History

Changed 3 years ago by Hubert

Screenshots

comment:1 Changed 3 years ago by Hubert

CDShell is version 2.1 and a graphical splash screen (resolution 640x480) is shown before the boot menu.

comment:2 Changed 3 years ago by sunlover

Could you please create an ISO with CDShell and a Linux, which we can use to reproduce the problem. Thanks.

Changed 3 years ago by Hubert

Logfile VirtualBox

comment:3 Changed 3 years ago by Hubert

I am not able to attach the ISO file. I get an internal error - seems that the file is too big (around 50MB). Please provide an email address to send the file to or offer an alternative solution. Thanks.

comment:4 Changed 3 years ago by sunlover

Please send me email to Vitali dot Pelenjow at oracle dot com and I'll reply you with upload instructions. Thanks.

comment:5 Changed 3 years ago by frank

  • Summary changed from VirtualBox 4.0.0: Screen destroyed after CDShell/bcdw menu to VirtualBox 4.0.0: Screen destroyed after CDShell/bcdw menu => Fixed in SVN

Most probably fixed in the next maintenance release.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in VBox 4.0.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use