VirtualBox

Ticket #7963 (closed defect: fixed)

Opened 3 years ago

Last modified 2 weeks ago

Minimize button in fullscreen on Mac OSX does not work

Reported by: rumen Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.0.0 Keywords: minimize fullscreen
Cc: Guest type: other
Host type: Mac OS X

Description (last modified by frank) (diff)

For some reason the minimize button [_] on the toolbar on Mac OS X has no effect when the machine is in full screen mode. The other two buttons and [X] work as they should. It was the same back in 3.2.X I upgraded to 4.0 hoping that this will work but unfortunately it still does not.

Change History

comment:1 Changed 3 years ago by alanbirtles

I am seeing the same problem in 4.0.10

comment:2 Changed 3 years ago by ecpost

I see the same problem in 4.0.12 and 4.1.2

comment:3 Changed 2 years ago by gpsfreak

I'm seeing it in 4.1.8 as well.

comment:4 Changed 2 years ago by capricorncyber

Correct, I'm seeing the same thing in 4.1.8. Anyone knows when/if this is going to be fixed?

Thanks.

comment:5 Changed 21 months ago by Commifreak

Can reproduce this on

MacOSX 10.7.4 and VBox 4.1.18 and an Windows XP Guest (latest VBox-Tools installed).

Something new here?

comment:6 Changed 21 months ago by frank

  • Description modified (diff)

No, sorry. This will probably not be fixed within the next weeks but we don't forget it. Currently our Mac OS X developers can't care about the GUI stuff but this will change in the future.

comment:7 Changed 15 months ago by nicc777

Hi - this is still not fixed and I think we all now waited long enough :-)

Mac OSX 10.8.2 with VirtualBox 4.2.6 r82870

comment:8 Changed 6 months ago by Arend99

Can you please look into this issue? It is pretty basic functionality. Thank you.

Last edited 6 months ago by Arend99 (previous) (diff)

comment:9 Changed 6 months ago by marin99

Still not fixed in 4.3

comment:10 Changed 3 months ago by Mohit

Folks, I suffer through this bug everyday - it is hard to shuffle between Virtualbox and my MacOS running on the same laptop. All engrs at my company use Macbooks and do their development on Linux running Virtualbox - so they all suffer from it.

It is marked as trivial and therefore never fixed. Given the amount of time this bug has been opened, I'd appreciate if someone increases its priority.

comment:11 Changed 3 months ago by frank

  • Priority changed from trivial to major

The bug priority does not reliably how VBox engineering prioritizes this bug. The priority field has some rules but we don't do any commitment. In this case I think the problem is also that the fullscreen mode used by VirtualBox on OS X is not the native OS X fullscreen mode. Changing this is a lot of work.

comment:12 Changed 3 months ago by Alx

If you are looking at this bug, then the Cmd-H shortcut will come in handy as a work-around...

comment:13 Changed 2 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This can't be fixed, therefore in VBox 4.3.10 we removed the minimize button from the mini tool bar on OS X.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use