VirtualBox

Ticket #794 (closed defect: invalid)

Opened 14 years ago

Last modified 14 years ago

FATAL: Module vboxdrv not found.

Reported by: zdavatz Owned by:
Component: other Version: VirtualBox 1.5.2
Keywords: FATAL: Module vboxdrv not found. Cc:
Guest type: other Host type: other

Description

Hi

I just installed VirtualBox Version 1.5.2 OSE on my Gentoo with with Kernel 2.6.23.1 VirtualBox startsup fine but after building the vboxdrv module, it can not be found by /sbin/modprobe vboxdrv - I get FATAL: Module vboxdrv not found.

I done: cd ./out/linux.x86/release/bin/src make

Thank you for your Feedback.

Zeno

Change History

comment:1 Changed 14 years ago by sandervl73

If our binary package works, then you should take this up with the Gentoo guys. Perhaps you're doing something wrong or something is broken in their package.

comment:2 Changed 14 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

Not a bug. AFAIK, modprobe will not load a module unless it is installed first. Unless you are developing, I suggest that you use a ready-packaged version of VirtualBox.

comment:3 Changed 14 years ago by Technologov

Do: ./out/linux.x86/release/bin/src# insmod vboxdrv.ko

-Technologov

comment:4 Changed 14 years ago by phyzome

I tried installing VBox 1.5.0 from repository in Ubuntu 7.10 ("Gutsy Gibbon"), using the generic module. I received the same vboxdrv module error.

I managed to locate vboxdrv.ko but doing an insmod gave me an "Invalid module format" error.

comment:5 Changed 14 years ago by frank

'invalid module format' means that the module does most probably not match your current running kernel. Please could you try to upgrade to 1.6.0?

comment:6 Changed 14 years ago by phyzome

Alright, found my problem. I had both the generic and 386 kernels installed, but 386 was still the default. Booting to the generic one solved my problem. (Still using 1.5.0)

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use