VirtualBox

Ticket #7881 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

ubuntu package upgrade destroys .Virtualbox directory

Reported by: csfreak Owned by:
Priority: major Component: installer
Version: VirtualBox 4.0.0 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Doing an aptitude install virtualbox-4.0 virtualbox-3.2- (which should install 4.0 and remove, not purge 3.2) destroys the /home/<user>/.Virtualbox directory, which is where 3.2 stores vms without migrating the data to the newly created directory. This is almost certainly a packaging bug that has the potential to destroy all of the virtualbox data including config files, disk images, mounted isos, etc.

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by klaus

Very odd - VirtualBox install/uninstall doesn't touch .VirtualBox or any other VM directory. I can't even guess what might cause such a misbehavior. The installation of the new VirtualBox package should fail if there is any running VM or VBoxSVC from the previous install. So there can't be two VBoxSVC processes accessing the same config files, destroying them accidentally with concurrent accesses.

comment:2 in reply to: ↑ 1 Changed 3 years ago by csfreak

Replying to klaus:

Very odd - VirtualBox install/uninstall doesn't touch .VirtualBox or any other VM directory. I can't even guess what might cause such a misbehavior. The installation of the new VirtualBox package should fail if there is any running VM or VBoxSVC from the previous install. So there can't be two VBoxSVC processes accessing the same config files, destroying them accidentally with concurrent accesses.

In this case, There wasnt a running VM. And the only VM was one I dont run regularly, which Is why I upgraded so quickly. I will take a look at the .deb and see If I can figure out what happened. I guess user error is always a possibility, however unlikely I think that answer is.

comment:3 Changed 3 years ago by csfreak

Looking through the packages, there is nothing that even mentions that folder. I guess It is safe to say that this is not a bug in the packaging. I still dont know what blew away that folder, but It at least isnt a bug here. This can be closed.

comment:4 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use