VirtualBox

Opened 14 years ago

Closed 13 years ago

#7877 closed defect (worksforme)

4.0.0 Linux GA not correctly passing Alt-F<anything> key strokes

Reported by: Jonathan Fosburgh Owned by:
Component: guest additions Version: VirtualBox 4.0.0
Keywords: X11 linux Cc:
Guest type: Linux Host type: Windows

Description

In the 4.0.0 GA for Linux, attempts to enter, for instance, Alt-F2 to bring up the command runner for KDE results in, not only Alt-F2, being passed to the guest, but also Ctl-Alt-F2, bringing up the second virtual terminal on the console of the guest. Reverting to Beta4 additions (r69117) results in a return to the correct behaviour.

Attachments (2)

Sabayon-2010-12-22-11-53-24.log (91.5 KB ) - added by Jonathan Fosburgh 14 years ago.
Using the 4.0.0 GA
Sabayon-2010-12-22-12-23-50.log (76.3 KB ) - added by Jonathan Fosburgh 14 years ago.
Using Beta4 GA

Download all attachments as: .zip

Change History (6)

by Jonathan Fosburgh, 14 years ago

Using the 4.0.0 GA

by Jonathan Fosburgh, 14 years ago

Using Beta4 GA

comment:1 by Frank Mehnert, 14 years ago

Cannot reproduce this. Alt-F2 shows run command while Host+F2 switches to the other terminal.

comment:2 by Michael Thayer, 14 years ago

Does this behaviour return if you reinstall the 4.0 Guest Additions? I'm somewhat surprised, as the Additions have nothing to do with keyboard handling, although it could be some strange indirect interaction.

in reply to:  2 comment:3 by Jonathan Fosburgh, 14 years ago

Replying to michael:

Does this behaviour return if you reinstall the 4.0 Guest Additions? I'm somewhat surprised, as the Additions have nothing to do with keyboard handling, although it could be some strange indirect interaction.

Very strange. Now it doesn't do it with the 4.0 GA. I wonder what the chances are that there was a brief period of time when one of the Ctl keys on my keyboard got stuck. Still, it worked correctly while I was on Beta4, stopped working immediately after launching the release, and then started working immediately when I started up the Beta4 GA. No changes were made to the guest in that time that I can think of.

comment:4 by Frank Mehnert, 13 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use