VirtualBox

Ticket #7798 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

VisualStudio 2010 hangs with 3D accel. enabled

Reported by: lkorokh Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.2.12 Keywords:
Cc: Guest type: Windows
Host type: Solaris

Description

Hello, If i install guest additions with 3d accel. support, VS2010 hangs on startup with white blank window. Without 3d accel. everything works fine. Please find crlog.txt attached. Guest - Windows 7.

PS. The same thing i found and with latest skype too.

Attachments

crlog.txt Download (164.9 KB) - added by lkorokh 3 years ago.
VS2010 startup CR log
ogl.txt Download (4.9 KB) - added by lkorokh 3 years ago.
VBTestOGL log file

Change History

Changed 3 years ago by lkorokh

VS2010 startup CR log

Changed 3 years ago by lkorokh

VBTestOGL log file

comment:1 Changed 3 years ago by equake

I have the same problem and still not fixed with 4.0 Upgrade

comment:2 Changed 3 years ago by mythril

Same problem here, with Visual Studio 2010 and VirtualBox 4.0.2.

comment:3 Changed 3 years ago by lkorokh

The same on VB 4.0.4, but skype works fine

comment:4 Changed 3 years ago by lkorokh

VS still hangs on 4.0.8

comment:5 Changed 3 years ago by arriu

Same here, under a WindowsXP guest. I have tried disabling the 3d acceleration of VS2010 but no luck. I have also tried a number of registry hacks, also with no success. The only thing that works is to not install the Direct3d support. Then OpenGL works but this is no good if you are developing applications which use Direct3d.

comment:6 Changed 3 years ago by jlabadie

Same problem here - Ubuntu 11.10 host, Windows 7 SP1 guest fully patched as of 7/8/11. Removed guest additions, reinstalled without Direct3D - VS2010 is now working.

comment:7 Changed 3 years ago by lkorokh

Hello, With VirtualBox 4.1 and WDDM driver VS works fine. The bug can be closed. Thanks.

comment:8 Changed 3 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 Changed 2 years ago by albertinix

Hello, I am using a Windows 7 guest with WDDM driver installed. Version of VirtualBox is 4.1.6. Windows Aero effects are disabled and running Visual Studio 2010 still doesn't work (it never worked for me, in any version). I am running the guest OS in 2 hosts: Windows XP 32-bit and Windows Server 2003 64-bit. Video memory allocated is 128 and 256 MB respectively. Host computer has integrated graphics, not powerful ones but still - DirectX 9 compliant and capable of running Windows Aero.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use