VirtualBox

Ticket #7758 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

"VBoxManage controlvm $name savestate" failes with "NS_ERROR_INVALID_ARG"

Reported by: martin_t Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Hi,

Basic info:

Host 32-bit Debian Linux, Dell Precision M4500. Virtualbox 3.2.10
Guest Win7 (32bit).

Problem: I try to save the state of my running guest from terminal because my X server screwed up (which might be another bug). I googled out that by calling

VBoxManage controlvm Win7 savestate

I should be able to save the state of the running VM. When I issue the command I get the following response:

mnt@localhost:~$ VBoxManage -nologo list runningvms
"Win7" {e7f536be-16f6-4a98-b3cb-cd8939917b58}
mnt@localhost:~$ VBoxManage controlvm Win7 savestate
Oracle VM VirtualBox Command Line Management Interface Version 3.2.10_OSE
(C) 2005-2010 Oracle Corporation
All rights reserved.

ERROR: code NS_ERROR_INVALID_ARG (0x80070057) - Invalid argument value (extended info not available)
Context: "SaveState(progress.asOutParam())" at line 165 of file VBoxManageControlVM.cpp

The outcome of the command is that the Virtual Machine is shut down instead of the state is saved.

Attachments

VBox.log Download (62.2 KB) - added by martin_t 3 years ago.
VBox.log file.

Change History

Changed 3 years ago by martin_t

VBox.log file.

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.2.12 / 4.0.2. Can't reproduce this here.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use