VirtualBox

Ticket #7648 (closed defect: obsolete)

Opened 3 years ago

Last modified 3 months ago

virtualbox doesn't startups, floating point exception

Reported by: rsaucedomx Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

When trying to startup virtualbox immediately got the message "floating point exeption", I'm using opensuse 11.3 kernel :Linux 2.6.34.7-0.4-desktop i686, 4.4.4 (KDE 4.4.4) "release 3", Processor: Intel(R) Core(TM) Duo CPU T2700 @ 2.33GHz, RAM: 2GB, Swap: 4GB

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by michael

Which VirtualBox package did you install? If you installed the "all distributions" one, could you try with the SUSE-specific one?

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 3 years ago by rsaucedomx

I installed the BIN version and OSE version (installed from OpenSuse one click site) on both of them I got the same behavior, after doing tests I found that the problem is some type of incompatibility with NVIDIA driver 260.19, when I remove it and use another driver (noveau for example) I can start again VirtualBox, but if I don't use NVIDIA drivers the temperature of the processor is not well controled.

comment:3 in reply to: ↑ 2 Changed 3 years ago by rsaucedomx

Just some additional information, I tried also with different kernels (default and desktop), the graphics card I'm using is NVIDIA QUADRO FX1500M

comment:4 follow-up: ↓ 5 Changed 3 years ago by michael

You might still try the following (in this order). The first thing would be to start VirtualBox from the command line as follows:

$ VirtualBox -graphicssystem raster

The second would be to try the "all distributions" installer from virtualbox.org.

comment:5 in reply to: ↑ 4 Changed 3 years ago by rsaucedomx

Hi Michael,

The first option didn't work, the last one worked perfectly, THANKS A LOT !!

comment:6 Changed 3 years ago by michael

It might be an issue in your system Qt library then - or the style you are currently using - as our "all distributions" installer bundles its own copy of the library.

comment:7 Changed 3 years ago by rsaucedomx

Do you want me to do some additional test?

comment:8 Changed 3 years ago by michael

I suppose you could try changing Qt styles to see if that makes a difference. You might also report this on the SUSE bugtracker. It depends how badly you want to solve this, or whether you are happy to use the "all distributions" version of VirtualBox.

comment:9 Changed 3 years ago by ViDeo

Just the same issue, started after NVIDIA properietary driver upgrade openSuse 11.3 Virtual Box 3.2.10 (both OSE and non-OSE)

deo@Jah:/home/common/downloads> VirtualBox -graphicssystem raster 
/usr/bin/VirtualBox: line 4: 23621 Floating point exceptionLD_LIBRARY_PATH="/usr/lib/virtualbox${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}" /usr/lib/virtualbox/VirtualBox $@

"all distributions" package runs fine.

comment:10 Changed 3 years ago by tr3027

Hi all, just for further information...

I'm using openSUSE 11.3 (with a few extra repositories, manually updating once a week) with nVidia drivers (currently 260.19.21). I've the same troubles as described here with VirtualBox installed from the virtualbox.org's repository (currently VirtualBox-3.2-3.2.12_68302_openSUSE113-1.i586). Right after installing VirtualBox I can start and use it as usual. Upon restart of my notebook I get the "floating point exception" error when I try to start it.

I found out the following resolves it for me

sudo zypper in -f VirtualBox-3.2

VirtualBox works than fine until the next openSUSE restart. Forcing zypper to reinstall VirtualBox from the repository is needed to get it work again.

comment:11 Changed 3 years ago by ViDeo

in my case this issue was also solved by reinstallation until the next reboot. So I should reinstall VB after each shutdown.

comment:12 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use