VirtualBox

Ticket #760 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

wrong device name in the cdrom select list

Reported by: victor Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

It also list my mobile hardisk (/dev/sda1 /dev/sda2) in the cdrom select list.

It dosen't happen in the early version.

Attachments

cdout Download (2.9 KB) - added by victor 7 years ago.
lshal output for storage.cdrom
lshal.output Download (115.3 KB) - added by victor 7 years ago.

Change History

comment:1 Changed 7 years ago by michael

Which Linux distribution are you using? And could you look through the output of the 'lshal' command for sections containing "storage.cdrom" and see what the 'block.device' entries in those sections are set to?

comment:2 Changed 7 years ago by victor

  1. ubuntu 7.04 feisty
  1. bolck.device = '/dev/hda' (string)

Changed 7 years ago by victor

lshal output for storage.cdrom

comment:3 Changed 7 years ago by michael

It looks like something is messed up on your system, but we have had a few similar reports - perhaps hal is broken in some way, or breaks easily.

comment:4 Changed 7 years ago by victor

I have three computer in my office, every one have the same problem.

comment:5 follow-up: ↓ 6 Changed 7 years ago by michael

Are you using the standard Ubuntu Feisty kernel? And the versions of udev, hal, etc which come with the distribution? And is your system up-to-date? The reason I am asking is that hal failures sometimes occur when the kernel, hal and udev are not in sync.

comment:6 in reply to: ↑ 5 Changed 7 years ago by victor

Replying to michael:

Are you using the standard Ubuntu Feisty kernel?

Yes.

And the versions of udev, hal, etc which come with the distribution? Yes.

And is your system up-to-date? Yes.

The reason I am asking is that hal failures sometimes occur when the kernel, hal and udev are not in sync. I can confirm that they are all in sync. And there is only one device(/dev/cdrom) in the select list when I switch back to version 1.4.0

comment:7 Changed 7 years ago by victor

Maybe the following info will be helpful.

hal-find-by-property --key 'storage.drive_type' --string 'cdrom'

/org/freedesktop/Hal/devices/storage_model_Optiarc_CD_RW_CRX880A

comment:8 Changed 7 years ago by michael

Would you be able to attach the entire output of lshal?

Re your last comment, that is in fact the same information that you privided originally, but hal says that the block device ("hal-get-property --udi <udi> --key 'block.device'") for that CDROM is /dev/hda according to the information you provided above, which was why I was wondering about a problem with your system setup.

Changed 7 years ago by victor

comment:9 Changed 7 years ago by victor

I've found a workaround solution, just see ticket 775.

comment:10 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This is fixed in VirtualBox 1.5.4. The hal stuff was just not loaded properly. Closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use