VirtualBox

Ticket #757 (closed defect: fixed)

Opened 7 years ago

Last modified 5 years ago

NAT'ed NIC speed on XP VM

Reported by: cmanucy Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 1.5.0 Keywords: link speed 10Mbps XP Guest
Cc: Guest type: other
Host type: other

Description

I noticed a closed ticket 2 months ago from someone complaining about a 10Mbps NIC - I'm having the same issue.

FC7 host on 1Gbps physical NIC - limited to 10Mbps adapter in the VM. This has been confirmed by the speed (or lack thereof) of a file transfer across the network onto the VM. Very slow. I did not see any options to control link speed on the adapter.

VMWare server 1.0.3+ doesn't have this same issue on this hardware. Happy to provide any additional information to help resolve this matter.

Change History

comment:1 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

The problem you are having is more likely due to the fact that you are using NAT. For high-speed networking you are better to use host interface networking.

comment:2 Changed 6 years ago by chdh

  • Status changed from closed to reopened
  • Resolution invalid deleted

I have the same problem. The virtual network is very slow. I'm using Virtualbox to run MS SQL Server in a VM, but the communication is too slow.

Host interface networking is even slower than NAT.

I used NETIO from  http://www.ars.de/ars/ars.nsf/docs/netio to measure network throughput.

My configuration:

  • Virtualbox 1.5.2.
  • CPU: Pentium 1.9 GHz. 1.5 GB RAM.
  • OS (host and guest): WinXP SP2
  • Host additions are installed in the guest OS.
  • I used a simple direct virtual host interface (HIF), without bridging or routing, created by "VBoxManage createhostif ...", using static IP addresses on both sides.

NETIO throughput results for 4KB packet size:

  1. NAT host-to-guest with port-forwarding: 4861 / 6210 KByte/s (TX/RX)
  2. NAT guest-to-host: 6306 / 4872 KByte/s
  3. HIF host-to-guest: 1671 / 3171 KByte/s
  4. HIF guest-to-host: 3757 / 1577 KByte/s

Why is the host interface networking connection so slow?

comment:3 Changed 6 years ago by miltondf

we have an application CPU reaches 85% and up once the network its utilize at its maximum. we're currently bridging the networkcards. We've also tested by plugging in (magic jack) which is a voice phone system onto the usb of the virtualbox and when it is being used the quality is horrible due to slowness within the virtual network. if we have it under the regular host it works fine. this we think is the cause of many slowness issues with sql, file server or whataver that people are mentioning about. we'd like to see if maybe we can increase the mb to 10 or 100, we try to run a ftp server to test the line and we only get up to 5mbps if we put a server on this it would be too slow to run properly.

comment:4 Changed 6 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Try again with 1.6.0 and report back if it's still relevant. Thanks.

comment:5 Changed 6 years ago by jtrumpet207

  • Status changed from closed to reopened
  • Resolution fixed deleted

I'm having the same problem, AND I've updated to 1.6. I'm currently using NAT with the intel pro/1000 network device with an xubuntu host running windows XP. Please post some help.

comment:6 Changed 6 years ago by frank

  • Component changed from other to network

comment:7 Changed 6 years ago by ergosteur

I've got the same problem with a Windows XP host and 3 different VMs: Windows Server 2008, Server 2003 and Xubuntu 8.04. The virtual machines see the link speed as 100 mbps, but the XP host insists that the "Virtualbox Host Interface 1" is 10mbps.

comment:8 Changed 5 years ago by frank

  • Component changed from network to network/NAT

comment:9 Changed 5 years ago by Hachiman

  • Status changed from reopened to closed
  • Resolution set to fixed

Try again with 3.0.4

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use