VirtualBox

Ticket #7535 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

loading vboxdrv fails with supdrvGipCreate: failed to allocate the GIP page

Reported by: scai Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Hi,

Installing vbox or running /etc/init.d/vboxdrv setup fails during the module loading step, here is the output of dmesg:

vboxdrv: Trying to deactivate the NMI watchdog permanently...
vboxdrv: Successfully done.
vboxdrv: Found 1 processor cores.
supdrvGipCreate: failed to allocate the GIP page. rc=-8

System: Debian GNU/Linux squeeze/sid, kernel 2.6.32 (package version 2.6.32-24)

This also happens with older versions, for example 3.1.8, but only since upgrading the kernel package from version 2.6.32-23 to 2.6.32-24. With version 2.6.32-23, this problem does not occur, loading of the module succeeds.

Regards, Alex

Change History

comment:1 Changed 4 years ago by frank

I tried to reproduce this issue locally and saw this message once and then never again. If you reboot your host, does the vboxdrv module always fail with the 2.6.32-24 kernel?

comment:2 Changed 4 years ago by frank

Note that the linux-headers-* packages must exactly fit the linux-image-* packages. Actually I think there is a bug, the Debian kernel package maintainer should have changed the extra version from -5 to -6 because the -23 sources will not fit the -24 image/modules and vice versa.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to invalid

Well, that's most likely the case.

comment:4 Changed 4 years ago by scai

You are right, upgrading linux-headers-* fixed the problem. Strangely this never happended before.

Thanks for the hint.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use