VirtualBox

Ticket #751 (closed defect: invalid)

Opened 7 years ago

Last modified 6 years ago

Strange CPU usage between guests

Reported by: hege Owned by:
Priority: minor Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

I have VBox 1.5.0 on XP host.

2 guests, XP and Linux, both idling at 0%. Additions installed.

When I stress Linux guest with compiling etc, hosts task manager says CPU usage is:

VirtualBox.exe 50-80% (Linux guest)
VirtualBox.exe 20-50% (XP guest)

When I stress XP guest, the usage looks normal:

VirtualBox.exe 0% (Linux guest)
VirtualBox.exe 99% (XP guest)

Why does the usage of Linux guest affect the XP process? Is this a bug or some architecture stuff I missed? The Linux guest does seem sluggish when compiling stuff etc compared to VMware.

Change History

comment:1 Changed 6 years ago by hege

While compiling in Linux guest, the CPU is split 50/50 with idle Windows guest. When I shutdown the Windows guest, then Linux guest gets happily up to 99% and compiling noticeably speeds up. Really irritating!

comment:2 Changed 6 years ago by hege

The version I'm using is 1.5.2 now. My host CPU single 2Ghz Athlon XP.

comment:3 Changed 6 years ago by hege

Seems to be something funny with process priorities.

If I change a guest to LOWER priority than the other one, then the lower priority one gets 99% like it's supposed to.

comment:4 Changed 6 years ago by hege

One way to replicate this with one guest running is to play some video. When the video player is at same or higher priority than guest, then the guest process uses CPU for no apparent reason. When I lower player priority below guest, everything returns to normal.

Maybe it has something to do with graphics, since running high CPU applications like prime95 doesn't get this effect.

comment:5 Changed 6 years ago by Technologov

This looks like a duplicate of bug #824.

-Technologov

comment:6 Changed 6 years ago by hege

Looks? Did you read anything? It's nothing like it.

By the way, I can't assist anymore solving this bug if needed. I replaced my single Athlon with Quad Core. I can't see any slowdown effects anymore due to the faster system. ;)

comment:7 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

Closing this as obsolete as it is relevant to VirtualBox 1.5.0.

comment:8 Changed 6 years ago by hege

Relevant how? I said I upgraded to 1.5.2, also the same problem was with 1.5.4. But who cares. You should give permissions for submitter to change the version tag.

comment:9 Changed 6 years ago by michael

Perhaps I was a little too fast there, but since you can no longer reproduce the issue it does not really seam relevant anymore. Yes, you are right about the version tag permissions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use