VirtualBox

Ticket #748 (closed defect: duplicate)

Opened 7 years ago

Last modified 6 years ago

Error: "A Debugger Has Been Detected"

Reported by: squarebottle Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords: debugger game
Cc: Guest type: other
Host type: other

Description

I'm trying to install Red Alert 2 on my WinXP Pro virtual machine, but it won't let me. It says, "A debugger has been detected. Please turn off the debugger and restart the installation." Then, it exits. I've tried running it in compatibility mode for Win2000 and Win98, but got the same message. I was able to play Red Alert 2 using VMWare Server, so I know it's possible to play inside of a virtual machine.

Change History

comment:1 follow-up: ↓ 2 Changed 7 years ago by sandervl73

It probably tries some debugging features, noticed some incorrect behaviour and drew this conclusion.

comment:2 in reply to: ↑ 1 Changed 7 years ago by squarebottle

Replying to sandervl73:

It probably tries some debugging features, noticed some incorrect behaviour and drew this conclusion.

Yes, but what now? Seems to me that there is a bug in VirtualBox if it is feeding some "Hi, I'm a debugger!" data to the programs in virtual machine it is hosting. Unless of course there's some feature that I should turn off that I'm not aware of.

comment:3 Changed 7 years ago by frank

Of course VirtualBox does not feed something like that. It is possible that some register is incorrect emulated by VirtualBox which is interpreted badly by the guest application. This will be fixed but we can not guarantee you any deadline. To blame VirtualBox for any of those bugs is not fair in every case because the x86 architecture is very difficult to virtualize (greetings to Intel and IBM). The fact that an application works well with VMware could mean that they found their own hack to overcome an x86 limitation.

comment:4 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Duplicate of 477.

comment:5 Changed 6 years ago by ben

  • Status changed from closed to reopened
  • Resolution fixed deleted

Reopened

I just tried running Command&Conquer General, and I got the same message (Running version 1.6.0 on MacOS X 10.5)

FYI, there is a  Microsoft kb article about that (of course not applicable, but it might help, who knows ...)

comment:6 Changed 6 years ago by ben

Oops, sorry, did not saw the duplicate message ...

Copy/Pasting to  issue477

comment:7 Changed 6 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use