VirtualBox

Ticket #7438 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Export/Import of appliance is broken 3.2.x with more than 1 virtual disk

Reported by: javaboyuk Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.2.8 Keywords: export import
Cc: Guest type: Windows
Host type: Solaris

Description

To reproduce (on 3.2.8) on Solaris 10u8 fully patched (July2010)

Create a virtual machine (64bit, solaris guest in my case) Create two hard disks on the same sata controller create IDE contorller with CDROM (no image in my case)

Export it. View the xxx.ovf file, see the attached references for the sata controller, they are the same UUID (and its the 2nd disk in my case)

Import it. The import completes with no issue. BUT ITS WRONG you've lost the first disk image its a duplicate of the first with a "-1" added. Booting it would fail if you had installed the an OS on the first drive and had say application say oracle on the 2nd disk with a sig error as there would no longer be an O/S see bug #7343.

This is reported in a different way in bug #7343

Work around:NONE as you can't edit the xxx.ovf file due to the check-sum on the file. Possibly copy the images over manually and create everything by hand, but thats not really creating an appliance is it :-)

Change History

comment:1 Changed 4 years ago by javaboyuk

Made a mistake in the typing : Import it......its a duplicate of the Second (2nd) disk....... not the first as I wrote, sorry about that.

comment:2 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Seems that this is a duplicate of #7366.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use