VirtualBox

Ticket #7417 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Apple keyboard problem with backslash key

Reported by: lpineiro Owned by:
Priority: minor Component: other
Version: VirtualBox 3.2.6 Keywords: keyboard mapping
Cc: Guest type: Windows
Host type: Mac OS X

Description

I am using VirtualBox 3.2.6, with Mac OS X 10.6.4 as host OS and Windows XP SP3 as guest OS. I have installed the VBox Guest Additions.

The keyboard is a Macbook Pro one and works fine except for the backslash key on the upper-left and the '<' key close to the cap-shift key. They are inverted in the virtual machine, i.e., pressing '\' gives you '<' and the other way round.

Change History

comment:1 Changed 4 years ago by michaln

What keyboard layout does the laptop have? What keyboard layout is selected in the guest?

comment:2 Changed 4 years ago by holdrio

I have got the same problem using VirtualBox 3.2.8 on a MacBook as host and Windows XP as a client. The < and > keys are on the Mac keyboard left of the 'Y' but on VirtualBox those are on the uppler left corner (replacing the ).

comment:3 Changed 4 years ago by Cubytus

Still the same with 3.2.10. OS X host, Linux guest. As well, characters using the "alt" key on the Mac are not available in the guest: that includes, on my layoutL |{}[]¬°<>, and «». These are quite commonly used in the command line.

This bug has lasted since at least 2 years. A bug fix would be more than welcome, since it's an easily identifiable and reproducible bug.

comment:4 Changed 4 years ago by michaln

It may well be easily reproducible - on your Mac, not on ours. So far no user thought it was worth their time to report such essential data as the keyboard layout used on the host and in the guest. We have plenty of bug reports that do provide complete information to look at instead...

comment:5 follow-up: ↓ 6 Changed 3 years ago by Bizatanium

Install the Apple Boot Camp drivers. This is a known issue across most virtual software packages.

(Edited by Michael)

comment:6 in reply to: ↑ 5 Changed 3 years ago by maiux

Replying to Bizatanium:

Install the Apple Boot Camp drivers. This is a known issue across most virtual software packages.

(Edited by Michael)

Hello, I have the same problem. I have a Logitech S530 keyboard, with "Italian PRO" layout.

The problem is not depending on OS guest: running a Live Distro, when I'm in the grub prompt (no keyboard mappings at all) the two keys backslash "\" and smaller-than "<" are swapped.

On my Mac the bug is reproducible also using using Mac OS X on-screen virtual keyboard and selecting "Italiano - PRO" layout: I think this is a way to reproduce it on yours.

I think the bug is also affecting the Host Key recognition: the control keys (apple, alternate, command) on the right aren't recognized right, but not on regular basis.

Let me know if I can help you with logs or scancode reading directly from my keyboard.

comment:7 Changed 3 years ago by michaln

  • Status changed from new to closed
  • Resolution set to duplicate

This is a duplicate of #2996.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use