VirtualBox

Ticket #7411 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

COM Port not visible in Guest machine. => Fixed in SVN

Reported by: sebbie Owned by:
Priority: critical Component: uart
Version: VirtualBox 4.0.6 Keywords: COM Port
Cc: Guest type: Windows
Host type: Windows

Description

The configured serial ports (COM Ports) do not function in the guest virtual machine

I configured my guest machine (running Windows XP) to use two serial ports (COM ports). Both COM ports are available on the host (Windows XP). But the COM ports do not run on the guest virtual machine. Why?
1: A look at Device Manager within the guest system shows NO COM Port available.
2: A test within the guest with an utility that requires these ports fail as if these ports were not there at all.
Even if I attach only one instead of two COM Port from the Host device, it still does not work.
What could be the cause of this? I will appreciate a fix of this bug.

Attachments

TPVBSeb317CN-2010-09-01-10-25-06.log Download (40.9 KB) - added by sebbie 4 years ago.

Change History

Changed 4 years ago by sebbie

comment:1 Changed 4 years ago by frank

  • Component changed from other to uart

comment:2 Changed 3 years ago by frank

  • Summary changed from COM Port not visible in Guest machine. to COM Port not visible in Guest machine. => Fixed in SVN

The reason were the missing entries in the ACPI tables. This will be fixed in the next major release.

comment:3 follow-up: ↓ 4 Changed 3 years ago by sbordoni

I have the very same problem with a WinXP VM hosted by v4.0.6 (on a WinXP PC).

comment:4 in reply to: ↑ 3 Changed 3 years ago by sbordoni

I am trying to use my physical COM3 to VM COM1...

Replying to sbordoni:

I have the very same problem with a WinXP VM hosted by v4.0.6 (on a WinXP PC).

comment:5 Changed 3 years ago by frank

I already said that this will be fixed in the next major release.

comment:6 Changed 3 years ago by sbordoni

Since this problem was reported for v3.2.8, I supposed the v4.x should be the 'next major release'.

Anyway, do you need some logs... to ease the fix?

comment:7 Changed 3 years ago by frank

  • Version changed from VirtualBox 3.2.8 to VirtualBox 4.0.6

No. The fix is already available in the public subversion repository and the next major release is not VBox 4.0 but the major release after it. The reason that we didn't backport the fix to VBox 4.0.x is that it could make Windows guest systems behave a little bit different (new hardware assistant popping up and so on).

comment:8 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.1.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use