Ticket #7367 (reopened defect)

Opened 5 years ago

Last modified 2 months ago

VBoxManage startvm command fails if no gui is available

Reported by: stoxx Owned by:
Priority: minor Component: VM control
Version: VirtualBox 3.2.8 Keywords: NS_ERROR_FAILURE
Cc: Guest type: other
Host type: Solaris

Description (last modified by frank) (diff)

when no X environment is present (ssh shell, no gui started on host, etc), this error message is presented:

tobo@elena:~$ VBoxManage startvm 2ct2 Oracle VM VirtualBox Command Line Management Interface Version 3.2.8 (C) 2005-2010 Oracle Corporation All rights reserved.

Waiting for the VM to power on... ERROR: The virtual machine '2ct2' has terminated unexpectedly during startup with exit code 0 Details: code NS_ERROR_FAILURE (0x80004005), component Machine, interface IMachine, callee tobo@elena:~$

which is far from elegant. Correct behaviour would be to require --type vrdp or such.

this is opensolaris host 111b or such.

please contact me at my registered address if further info is necessary.

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

comment:2 Changed 4 years ago by gcc

  • Status changed from closed to reopened
  • Resolution fixed deleted

Still happens in 4.1.14.

This failure mode is really unclear. The logs don't appear to say anything useful. Not even a google search turns up that this error can be caused by failing to specify --type headless when starting the virtual machine.

comment:3 Changed 3 years ago by frank

  • Description modified (diff)

Well, the error message I get when I try this is VBoxManage: error: Could not launch a process for the machine 'debian' (VERR_FILE_NOT_FOUND) .... I understand that in case there is no GUI application installed, the default type could be headless but OTOH I hesitate to implement that because this could also mean an installation problem.

comment:4 Changed 3 years ago by scai

Problem still exists:

$ VBoxManage --version
$ VBoxManage startvm "Build Server"
Waiting for VM "Build Server" to power on...
VBoxManage: error: The virtual machine 'Build Server' has terminated unexpectedly during startup with exit code 0
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Machine, interface IMachine
$ VBoxManage startvm "Build Server" --type headless
Waiting for VM "Build Server" to power on...
VM "Build Server" has been successfully started.

I suggest adding a clearer error message.

comment:5 Changed 2 months ago by a3nm

From my experience, the problem still exists with VBoxManage version 5.0.4_Debianr102546. When running VBoxManage startvm "Machine" in a terminal without graphical interface ($DISPLAY is empty), the following is output

Waiting for VM "Machine" to power on...
VM "Machine" has been successfully started.

However this actually doesn't do anything, and Machine is not listed when you do VBoxManage runningvms. Instead, you need to do VBoxManage startvm Machine --type headless for the machine to actually run.

I think the invocation without --type should display an error message when there is no graphical display, instead of failing silently while confusingly claiming that it succeeded. Also, it should probably suggest the --type variant.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use