VirtualBox

Ticket #7346 (closed defect: fixed)

Opened 4 years ago

Last modified 10 months ago

USB devices usually recognized as "unknown devices" in 3.2.8 on OSX

Reported by: masc Owned by:
Priority: critical Component: USB
Version: VirtualBox 3.2.8 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description (last modified by frank) (diff)

Host: OSX 10.6.4 Guest: Windows XP SP3 USB devices tested: Apple USB Host Controller, Windows CE/Mobile USB/Cradle connection

USB devices are only recognized correctly very sporadically and I only managed to do it a few times using following steps:

  • Detach incorrectly recognized "unknown device"
  • Close vbox window and cancel the shutdown/savestate dialog (suspend/resume messages will be logged in vbox.log)
  • Reattach usb device

Setting priority to critical, referring to USB component. Except for the workaround described above, which only works once out of 10-20 attempts, when the defect occurs, USB is mostly unusable.

Attachments

VBox.log Download (53.0 KB) - added by masc 4 years ago.
vbox.log
VBox_11-14-USB01.log Download (66.9 KB) - added by ChipMcK 3 years ago.
Vbox.log
2010-11-14-14-05-20.009-VBoxSVC-4257.log Download (310 bytes) - added by ChipMcK 3 years ago.
VBoxSVC log from folder Applications
VBox-USB07.tiff Download (46.9 KB) - added by ChipMcK 3 years ago.
USBFilter in use when failure occurred
VBox-USB09.tiff Download (45.2 KB) - added by ChipMcK 3 years ago.
a USBFilter that does not cause failure

Change History

Changed 4 years ago by masc

vbox.log

comment:1 Changed 4 years ago by masc

 http://forums.virtualbox.org/viewtopic.php?f=2&t=33052&start=0 might relate, different platforms though.

comment:2 Changed 4 years ago by masc

update: forget the replication steps I mentioned in the ticket description. I was first assuming the vbox state changes (suspend/resume) would have an effect, but it seems just timing related. I can also get devices to work by attaching/detaching them like a maniac using the usb icon in bottom statusbar of vbox window.

with both usb devices I tested (see description), looking at the icon's activity indication (orange/red circles blinking) is the fastest way to determine if the bug occurs or not.

when device attached correctly, icon will instantly start blinking. in most cases, when device is not recognized, it won't.

comment:3 Changed 4 years ago by masc

usb filter devices, like external harddisks, are also affected. once devices are correctly attached, it will also keep working across vm reboots. when the vm is stopped and restarted however (for configuration change eg.), the dilemma starts over again.

comment:4 Changed 4 years ago by iegorman

I had a similar problem with XP SP3 32-bit installed with 2 CPU.

I could not duplicate the problem with Ubuntu 10.04 LTS 64-bit or SuSE 11.2 32 bit.

When I used an IMATION USB "thumb" drive (with a write-protect switch), it would be recognized when switched to read-only (write-protected), but not when switched to read-write (writable).

But then I thought about the fact that I had just installed XP SP3, I compared my USB settings. On the other guest systems, I had defined one filter, with the "remote" field set to "no" and all other fields blank. On the XP guest, I had set the "remote" field to "any". When I changed the "remote" field to "no", XP would recongnize a writable USB drive.

I hope htis is useful information.

comment:5 follow-up: ↓ 7 Changed 3 years ago by masc

issue persists in 3.2.10.

comment:6 Changed 3 years ago by frank

  • Description modified (diff)

Changed 3 years ago by ChipMcK

Vbox.log

Changed 3 years ago by ChipMcK

VBoxSVC log from folder Applications

comment:7 in reply to: ↑ 5 Changed 3 years ago by ChipMcK

Replying to masc:

issue persists in 3.2.10.

Assuming I have related problem, to attach Logs VM defied with USBFilter fr WesternDigital External Drive, checked as Active Start the VM Did Eject from Mac OS X 10.6.5 (get same resolts with 10.6.4) Pulled Usb plug to device, await about 1 mun Plug in the device Devices --> USB Devices is empty, shows no devices at all - no iSigth, no bluetouth Vbox Window: VirtualBox --> Preferences --> General reset Hard disks, machines and VRDP When V is shutdown, status stays [Running' until Vbox quits

to attack VBox.log and a log from VBoxSVC that showed up in Folder Applications

Changed 3 years ago by ChipMcK

USBFilter in use when failure occurred

Changed 3 years ago by ChipMcK

a USBFilter that does not cause failure

comment:8 Changed 3 years ago by agentbrutus

Host: OS X 10.6.5 VBox: 3.2.10 Guest: Windows XP SP3

Issue still exists, I have managed to connect USB-to-Serial converter and Windows CE device only once or twice during countless attempts. Hard to predict when it is going to work. Firstly I thought it was related to compatibility to USB 1.1 vs USB 2.0, but further testing dismissed that option.

comment:9 follow-up: ↓ 10 Changed 3 years ago by omascia

I confirm huge issues (USB unusable) with Windows 7 64 bits guests at least. If the VM is not limited to 1 cpu, I cannot attach any USB device. If the VM is limited to 1 cpu, some devices attach, others fail working though they seem to attach.

Corsair Voyager GT 16 GB USB-flash : cannot be recognized and installed with cpu # > 1. Works with cpu # == 1.

Symbol MC 3800 portable barcode scanner, does not attach at all with cpu # > 1. With cpu # == 1, it fails a bit further, and it probably is because the model string is detected as "Symbö PocketPC Device" instead of "Symbol PocketPC Device" (note the strange extended char 'ö' (lowercase 'o' with a 'trema' on it) instead of the perfectly 7bits ascii "ol" -- the "ol" turns to "ö", which is really unexpected. And I think that on its side, Windows 7 itself has difficulties associating the right driver or configuration due to the naming issue.

comment:10 in reply to: ↑ 9 Changed 3 years ago by omascia

My findings are with Mac OS X 10.6.6. as host, Windows 7 64 bits as guests and Virtual Box 4.0.4. Should I open a distinct ticket due to the VirtualBox version difference ??

Replying to omascia:

I confirm huge issues (USB unusable) with Windows 7 64 bits guests at least. If the VM is not limited to 1 cpu, I cannot attach any USB device. If the VM is limited to 1 cpu, some devices attach, others fail working though they seem to attach.

Corsair Voyager GT 16 GB USB-flash : cannot be recognized and installed with cpu # > 1. Works with cpu # == 1.

Symbol MC 3800 portable barcode scanner, does not attach at all with cpu # > 1. With cpu # == 1, it fails a bit further, and it probably is because the model string is detected as "Symbö PocketPC Device" instead of "Symbol PocketPC Device" (note the strange extended char 'ö' (lowercase 'o' with a 'trema' on it) instead of the perfectly 7bits ascii "ol" -- the "ol" turns to "ö", which is really unexpected. And I think that on its side, Windows 7 itself has difficulties associating the right driver or configuration due to the naming issue.

comment:11 Changed 3 years ago by iegorman

I have posted information about similar problems (with linux and Windows XP guests on Mac OS hosts) to #7462. But I do not encounter any problems when the guest has only one CPU.

comment:12 Changed 10 months ago by ieg

confirmed working - VirtualBox 4.2.14, Mac OS X 10.8.4 host, Win XP SP3 guest with 2 CPU

Last edited 10 months ago by ieg (previous) (diff)

comment:13 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.14.

comment:14 Changed 10 months ago by ChipMcK

seem om v4.2.16 and OSX 10.8.4

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use