VirtualBox

Ticket #7296 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

VirtualBox 3.2.8 networking broken on OpenSolaris

Reported by: evanr Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.2.8 Keywords: VBox Client Networking
Cc: Guest type: Windows
Host type: Solaris

Description

I did a fresh install of VBox 3.2.8 on an OpenSolaris host running on a Toshibs A660 laptop. The results of the command "ifconfig -a" did not show a vboxnet and all VBoxs VMs I created did not have network access. I then checked another Toshiba laptop running VirtualBox version 3.6.2 and found that an "ifconfig -a" did list an entry for the "vboxnet" and that all the VBox VMs on that system did have network access. Finally I removed VirtualBox 3.8.2 from the non-networked host system, installed VirtualBox 3.6.2 and removed the 3.8.2 client and installed the 3.6.2 client -- all then functioning perfectly. The upshot is that I think there may be something wrong with the 3.8.2 host components (since the vboxnet does not show up via ifconfig") that is preventing the client components from working.

I've got screen-shots from the output of pkginfo and ifconfig for both the 3.8.2 and 3.6.2 versions of the software. With a little prodding I could probably be induced into running truss and/or Dtrace in both scenarios.

As I mentioned before, this was on a Toshiba A660 notebook.

Best wishes -- keep growing OpenSolaris and the regular Solaris as well!

Change History

comment:1 Changed 4 years ago by ramshankar

Were the OpenSolaris versions exactly the same in both the systems you tried? My assumption is perhaps something changed in 'nwam' which might be causing this.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use