VirtualBox

Ticket #7185 (closed enhancement: duplicate)

Opened 4 years ago

Last modified 3 years ago

[feature-request] Reverse Shared Folders

Reported by: Technologov Owned by:
Priority: major Component: shared folders
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: other
Host type: other

Description

It would be great to be able to mount running Guest's folders into Host's directory tree. Effectively making "reverse shared folders".


(by "yast")

There could be one useful thing to include which in fact wouldn't be to hard to implement. It should be possible that you can open any file on guest side using host process.

Use case:

User has Windows guest.

We wants to open one mp3 file using vlc player on linux.

To do so:

User right clicks on file

Clicks "Open file with host process"

Writes/selects "vlc".

Vlc is started and playing music on host side

Work flow when user wants to open a file with host:

Guest file is copied to temporary shared folder by guest additions

According process is called on host side to open a file

When process is closed, file might be copied back to guest side (to support writing)


The use case is described here:  http://forums.virtualbox.org/viewtopic.php?f=9&t=32912&p=147102#p147102

-Technologov, 17.7.2010.

Change History

comment:1 Changed 3 years ago by Technologov

Duplicate of Wish #7642. (I like #7642 description more.)

-Technologov

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use