VirtualBox

Ticket #7159 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Ubuntu VM doesn't resume

Reported by: andyp73 Owned by:
Priority: critical Component: VM control
Version: VirtualBox 3.2.10 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I have VirtualBox 3.2.6 running on a Windows 7 Ultimate (32bit) host running Ubuntu 10.04 (32bit) as a guest with guest additional 3.2.6 installed.

In normal operation the guest is running maximised giving a screen resolution of 1680x955 (screeen resolution in Windows is 1680x1050. On occasion the VM is closed by pressing the "X" in the top right corner and choosing the "Save machine state" option.

When I restart the VM its window is drawn off screen (beyond the top left corner somewhere I think) and I have to click "Show" with the VirtualBox GUI. This brings the VM window back onto the desktop but in very small size and with no content displayed in it. If I maximise the window then it just displays with a white background and the Ubuntu desktop (KDE) doesn't get displayed.

Log file is attached.

Andy.

Attachments

VBox.log Download (47.0 KB) - added by andyp73 4 years ago.
VirtualBox log file
VBox.2.log Download (73.9 KB) - added by ceb1000 4 years ago.
Ubuntu 10.04.1 64 bits on Windows 7 Home Premium 64 bits
VBox.3.log Download (45.8 KB) - added by fbenz 3 years ago.
Ubuntu 10.04 on Windows 7 Professional
VBox.4.log Download (64.8 KB) - added by fbenz 3 years ago.
Ubuntu 10.04 (64bit) on Windows 7 Professional (64bit), deactivated as much as possible, hard shutdown after line 730
VBox.5.log Download (42.8 KB) - added by andyp73 3 years ago.
Log file for openSUSE session which suspended but didn't resume correctly with VB 3.2.8
VBox.6.log Download (71.4 KB) - added by Notausstieg 3 years ago.
Ubuntu 10.04.1 LTS minimal VM on a Windows XP Home SP3 Host

Change History

Changed 4 years ago by andyp73

VirtualBox log file

comment:1 Changed 4 years ago by andyp73

Oops, forgot to add... the only way I have found to recover from this is to force the VM to shutdown and reboot it fully.

comment:2 Changed 4 years ago by nope

I have the same exact problem except I am running Windows 7 Ultimate 64-bit as the host and Ubuntu 10.04 64-bit as the guest. I also am able to recover by forcing the VM to close and reboot.

Changed 4 years ago by ceb1000

Ubuntu 10.04.1 64 bits on Windows 7 Home Premium 64 bits

comment:3 Changed 4 years ago by ceb1000

I have the same problem, but with VirtualBox 3.2.8 on 64-bit Windows 7 Home Premium. The guest is 64-bit Ubuntu 10.04.1.

On resuming the machine, no window is visible. If I click "show" on the main VirtualBox window, I get a tiny window at the top left of my Windows screen. If I drag the corner, I can make the title bar appear, but the window is just empty.

I've attached a log file where I resume the machine, see no display, and then power it down.

comment:4 Changed 4 years ago by ceb1000

I forgot to say that the problem appears to me to have started with 3.2.6; so far, I haven't seen the problem with 3.2.4.

comment:5 Changed 4 years ago by mvdh

The same issue appears on my Windows XP host with an Ubuntu 9.04 guest while using the latest Virtualbox version 3.2.8.

comment:6 Changed 3 years ago by fbenz

The issue still exits with VirtualBox 3.2.10. After saving the state of the machine there is no chance of getting it back to running without a reboot. I am running VirtualBox on Windows 7 Professional with Ubuntu 10.04 as a guest (VirtualBox 3.2.10 guest additions are installed).

The log file was created during resuming the guest system - without any visible result on the screen.

Changed 3 years ago by fbenz

Ubuntu 10.04 on Windows 7 Professional

comment:7 Changed 3 years ago by frank

Hmm, the log shows that the VM was successfully restored but then it did not show progress for some unknown reason. If you can reproduce this issue then you could try to disable selected VM features and check if it still happens. Start with the USB controller, then try to disable audio and so on.

comment:8 Changed 3 years ago by frank

  • Version changed from VirtualBox 3.2.6 to VirtualBox 3.2.10

Changed 3 years ago by fbenz

Ubuntu 10.04 (64bit) on Windows 7 Professional (64bit), deactivated as much as possible, hard shutdown after line 730

comment:9 Changed 3 years ago by fbenz

I deactivated as much as possible (USB, audio, network, nested paging, shared folder, IO-APIC) but the bug can be reproduced each time. If I remember correctly, the bug occurred the first time after updating to a 2.6.x version (possibly 3.2.6).

comment:10 Changed 3 years ago by andyp73

I haven't tried this under VirtualBox 3.2.10 as I have too many other issues running with that version and so I am still running 3.2.8.

However, I can verify that this is not just an Ubuntu related issue as I have an openSUSE 11.3 32bit virtual machine that behaves in exactly the same way.

Changed 3 years ago by andyp73

Log file for openSUSE session which suspended but didn't resume correctly with VB 3.2.8

comment:11 Changed 3 years ago by frank

So are there really only Windows hosts affected?

comment:12 Changed 3 years ago by frank

  • Priority changed from major to critical

comment:13 follow-up: ↓ 14 Changed 3 years ago by frank

Still not able to reproduce. How often do you observe this hang during restore? Every time, very often or only sometimes? It is sufficient to start a guest (tried Ubuntu Lucid here) or is some guest activity necessary (large amount of applications open, network activity, ...)? And how long do you wait between saving the VM and restoring the VM?

comment:14 in reply to: ↑ 13 Changed 3 years ago by andyp73

Hi Frank,

Typically this can be seen everytime the VM is suspended and it doesn't seem to make any difference how long the machine has been running. It even fails in this manner when just booted to the KDE desktop. To try and reproduce this use the following steps:

Boot the VM and login to X as a user.

Click on the Windows application close "X" to bring up the "Close Virtual Machine" dialog.

Choose "Save the machine state" and click OK. ...

comment:15 Changed 3 years ago by andyp73

In VirtualBox Graphical User Inteface select the saved machine and click on "Start".

When the machine has changed to "running" it isn't visible on the screen and so to get it displayed I have to click on the "show" button.

When the VM was suspended it was maximised but the VM window that gets shown is only something like 200 pixels by 100 and has a completely white background.

Maximising the window again just makes it fill the screen again but still only with a white background.

I am currently transferring my openSUSE hard disk image to a Linux host to see if that behaves the same way.

comment:16 Changed 3 years ago by Notausstieg

I can confirm this problem.

Using Windows XP Home SP3 as Host system with Ubuntu 10.04.1 LTS minimal. After state resume, the VM doesn't show up, but status is "Running". After use the Show-Button, the window frame show up, but without content (it uses the content from the window behind). Because it's an ambiguous window, the windows internal screenshot function is unable to create a screenshot.

Changed 3 years ago by Notausstieg

Ubuntu 10.04.1 LTS minimal VM on a Windows XP Home SP3 Host

comment:17 Changed 3 years ago by Notausstieg

I tried to save the state of my VM right after the Oracle Bootsplash disappears. But also there the problem still exists. After resume and using the Show-Button, an empty window appears. I also disabled all unnecessary features of my VM.

comment:18 Changed 3 years ago by nope

Here is a temporary solution that works for me.

After you resume and the window is off the screen, click show. A small portion of the screen will show up in the top left of the screen. Resize that window a bit to make the entire window appear on screen and then maximize the window. It will still have nothing in the window, but press Host+F (by default right ctrl) to maximize to the entire screen. For me, this works to bring the Ubuntu desktop back without having to shutdown and restart the VM. Doing Host+F again will put it back to windowed mode, but the Ubuntu desktop will still be displayed. I hope this helps others!

comment:19 Changed 3 years ago by Dsen

Is this issue happens with x11 (linux/solaris) guests only? It doesn't happens with windows guests on the same host?

comment:20 Changed 3 years ago by Notausstieg

Actually its not important which Guest you use. as mentioned above in comment 18, i try it after disappearing oracle boot splash. So i guess it is a general problem

comment:21 Changed 3 years ago by fbenz

Nothing has changed with the release of VirtualBox 3.2.12. The workaround described by nope is reliable, however, the bug is still annoying.

comment:22 Changed 3 years ago by aearenda

I have seen this exact same behaviour using 3.2.12 on Windows 7 hosting a Windows XP SP3 guest.

comment:23 follow-up: ↓ 24 Changed 3 years ago by mrzephy

I cannot believe something like this still was not fixed!

comment:24 in reply to: ↑ 23 Changed 3 years ago by nope

I had problems with this bug in many previous versions of VirtualBox, but I have been unable to reproduce it in 4.0.

comment:25 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Other feedback with VBox 4.0?

comment:26 Changed 3 years ago by Notausstieg

I can confirm that is has been fixed. On my Windows XP the saved VM resumes properly and show the VM Screen.

Thx for fixing.

comment:27 Changed 3 years ago by frank

Thanks for the feedback!

comment:28 Changed 3 years ago by ceb1000

So far, I haven't seen the problem with VirtualBox 4. Thanks for fixing this!

(64-bit Windows 7 as the host and 64-bit Ubuntu 10.04 as the guest.)

comment:29 Changed 3 years ago by frank

Thank you for the feedback as well!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use