VirtualBox

Ticket #7138 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Snow Leopard: NAT: Host Resolver not working. -> fixed in svn

Reported by: stepheneb Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

I have local domain names specified on my Snow Leopard host that resolve to 127.0.0.1 and normally use these on port 80 for web applications proxied with Apache virtual hosts. I would like to be able to use these domain names from my Windows XP guest to access the web applications running on the host.

When I switch the networking selection to NAT I get this error:

00:00:00.767 NAT: Host Resolver conflicts with DNS proxy, the last one was forcely ignored

and I am not able to resolve the local DNS names.

The dns entries are created two different ways on the MacOS X host (both ways work on the host).

Adding entries to /etc/hosts

27.0.0.1       testrails

Using the command line tool dscl

sudo dscl localhost -create /Local/Default/Hosts/smartgraph-demos IPAddress 127.0.0.1

Both of these domain names resolve to Rails applications served by Apache virtual hosts.

Testing from the host system:

testrails (in /etc/hosts):

$ curl -I http://testrails
HTTP/1.1 200 OK
Date: Wed, 07 Jul 2010 22:18:47 GMT
Server: Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8l DAV/2 Phusion_Passenger/2.2.15
Last-Modified: Wed, 23 Jun 2010 15:03:25 GMT
ETag: "7b7f6a-1ace-489b3d6ef4940"
Accept-Ranges: bytes
Content-Length: 6862
Content-Type: text/html

smartgraph-demos (using dscl):

$ curl -I http://smartgraph-demos
HTTP/1.1 200 OK
Date: Wed, 07 Jul 2010 22:17:44 GMT
Server: Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8l DAV/2 Phusion_Passenger/2.2.15
Last-Modified: Wed, 23 Jun 2010 15:03:25 GMT

When I run nslookup in the Windows XP command prompt it reports:

*** Can't find server for address 10.0.2.3: Non-existent domain
*** Default servers are not available
Default Server: Unknown
Address: 10.0.2.3

Further nslookup queries to valid non-local dns names complete successfully however queries for the locally-defined dns entries produce "Non-existent domain" errors.

Attachments

xp-2010-07-07-18-05-50.log Download (43.6 KB) - added by stepheneb 4 years ago.
VBox.log

Change History

Changed 4 years ago by stepheneb

VBox.log

comment:1 Changed 4 years ago by Hachiman

I've been able reproduce an issue. Looks like it's specific for win XP guests.

comment:2 Changed 4 years ago by Hachiman

This happens because while resolving windows add dot at the end of the request e.g. in your case it request not "smartgraph-demos", but "smartgraph-demos.", that confuses host resolver.

comment:3 Changed 4 years ago by Hachiman

Could you please replace VBoxDD.dylib in your VirtualBox installation with downloaded one ( VBoxDD)? Please let me know if these bits fixes issue for you.

P.S. while replacing please save original DSO in some safe place :).

comment:4 Changed 4 years ago by Hachiman

  • Summary changed from Snow Leopard: NAT: Host Resolver not working. to Snow Leopard: NAT: Host Resolver not working. -> fixed in svn

comment:5 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use