Ticket #7136 (closed defect: obsolete)

Opened 6 years ago

Last modified 2 months ago

3.1.2 with GuestAdditions >= 3.1.0 makes VisualStudio native C++ compiler throw error C1085

Reported by: ea1145 Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 3.1.2 Keywords: VS2008 C1085 precompiled header
Cc: Guest type: Windows
Host type: Windows

Description (last modified by aeichner) (diff)

I'm running VirtualBox 3.1.2 on a Windows XP host. Guest Additions were originally 3.1.2 as well.

While compiling a native C++ project (hosted on a shared folder) using Visual Studio 2008 the compiler threw a fatal error C1085, Cannot write precompiled header file.

Some investigation made me believe that this could be an issue of the Guest Additions. Subsequently, I uninstalled Guest Additions 3.1.2 and installed 3.0.4. The problem was gone.

I then tried several older and newer versions of the Guest Additions. The last one that works for me is 3.0.14, the first one I found not working is 3.1.0. Even the latest one (3.2.6) does not work.

The behavior is reproducible 100% with my setup.


VBox.log Download (51.4 KB) - added by ea1145 6 years ago.
VirtualBox session log

Change History

Changed 6 years ago by ea1145

VirtualBox session log

comment:1 Changed 2 months ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use