VirtualBox

Ticket #7110 (new defect)

Opened 4 years ago

Last modified 14 months ago

Compiz no longer works on OpenSolaris b142

Reported by: calum Owned by:
Priority: major Component: GUI/compiz
Version: VirtualBox 3.2.6 Keywords:
Cc: Guest type: Solaris
Host type: Mac OS X

Description

OpenSolaris b142, VirtualBox 3.2.6, latest guest additions installed. Selecting any System>Prefrences>Appearance>Visual Effects other than None gives the error "Desktop effects could not be enabled". Running '/usr/bin/compiz --replace' only gives messages about not being able to restore a saved metacity session. (And in fact, this time, it's just hung my entire session.)

Attachments

glxinfo.out Download (12.9 KB) - added by aimone 18 months ago.
glxinfo output on Solaris 11 11/11 Guest under VBox 4.1.22 on ADM Phenom QUAD running Vista/64
compiz-11-2012-10-04-09-28-36.log Download (85.5 KB) - added by aimone 18 months ago.
VirtualBox log of compiz failure.

Change History

comment:1 Changed 4 years ago by calum

Still not working with VBox 3.2.10 + associated guest additions, Solaris 11 b149.

comment:2 Changed 3 years ago by calum

Still not working with VBox 4.0.2 + associated guest additions, Solaris 11 b156.

comment:3 Changed 2 years ago by calum

Still not working with 4.1.6 and Solaris 11 FCS, which is a bit more troubling.

comment:4 Changed 19 months ago by aimone

VBox 4.1.22 w/GA installed
Host: Vista 64 on AMD Phenom 9650 QUAD
Guest: Solaris 11 11/11 fails to run compiz.

I also have an Ubuntu 12.04 LTS guest on which compiz runs without error.

comment:5 Changed 18 months ago by michael

Does the "glxinfo" command, run in the Solaris guest, say that you are using VirtualBox (Chromium) or software rendering?

comment:6 Changed 18 months ago by michael

Nevermind, seen your mailing list message.

Changed 18 months ago by aimone

glxinfo output on Solaris 11 11/11 Guest under VBox 4.1.22 on ADM Phenom QUAD running Vista/64

Changed 18 months ago by aimone

VirtualBox log of compiz failure.

comment:7 Changed 18 months ago by michael

When I tried to start Compiz on a Solaris guest I got an Xorg crash with a backtrace in Xorg.0.log(.old). Is that what you are seeing?

comment:8 Changed 18 months ago by aimone

No. Xorg seems to work, but when I try to start compiz as the window manager it complains and exits.

/usr/bin/compiz-bin (core) - Fatal: Support for non power of two textures missing
/usr/bin/compiz-bin (core) - Error: Failed to manage screen: 0
/usr/bin/compiz-bin (core) - Fatal: No manageable screens found on display :0.0

comment:9 Changed 14 months ago by misha

IS this still an issue for you? If so could you try with the newest VBox 4.2.8 and 4.2.8 additions, and if the problem persists, attach a VM log and also /var/log/Xorg.*.log X server log files from your Guest.

comment:10 Changed 14 months ago by calum

Still same problem here, but I'm using latest internal build of Solaris with workaround for X.org 1.13.1. If it's not a problem to post those logs here, I'll do so later. Otherwise, I can file internally.

Last edited 14 months ago by calum (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use