VirtualBox

Ticket #7066 (closed defect: fixed)

Opened 10 years ago

Last modified 10 years ago

3D Acceleration on 64-bit WindowsXP guests still broken -> Fixed in SVN

Reported by: Technologov Owned by:
Component: 3D support Version: VirtualBox 3.2.6
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

Host: Windows XP 32-bit, ATI Radeon HD 3850, VBox 3.2.6

Guest: Windows XP x64

Starting any OpenGL application works in 'software rendering' mode only; fails to start 3D acceleration. All my applications are 32-bit on 64-bit OS.

-Technologov, 25.6.2010.

Attachments

Windows XP 64bit-2010-06-25-20-53-00.log Download (66.3 KB) - added by Technologov 10 years ago.
Windows XP 64bit-2010-06-25-20-53-00.log

Change History

Changed 10 years ago by Technologov

Windows XP 64bit-2010-06-25-20-53-00.log

comment:1 Changed 10 years ago by Technologov

I have tried 'Tux Racer' and 'Really Slick screen savers'; both are OSS programs.

comment:2 Changed 10 years ago by Technologov

NOTE: There is no problem with Windows 7, 64-bit guest.

comment:3 Changed 10 years ago by leonid

  • Summary changed from 3D Acceleration on 64-bit Windows guests still broken to 3D Acceleration on 64-bit WindowsXP guests still broken

comment:4 Changed 10 years ago by leonid

  • Summary changed from 3D Acceleration on 64-bit WindowsXP guests still broken to 3D Acceleration on 64-bit WindowsXP guests still broken -> Fixed in SVN

comment:5 Changed 10 years ago by Technologov

Status Update:

both Vista x64 and XP x64 guests fail to accelerate 32bit OpenGL apps. Only Windows 7 x64 works.

Host: Windows XP 32-bit, ATI Radeon HD 3850, VBox 3.2.8

Guest: Windows XP x64 + TuxRacer

Guest2: Windows Vista x64 + TuxRacer

-Technologov

comment:6 Changed 10 years ago by leonid

The fix is after 3.2.8, no wonder it doesn't work.

Anyway thanks for pointing out that vista64 wasn't working, as it was reported as working before. That's fixed too.

comment:7 Changed 10 years ago by Technologov

leonid: small correction: I reported that XP x64 didn't wotk, but Win 7 x64 did work. I never reported anything about Vista x64 on VBox 3.2.6 -- it was your own (false) conclusion.

Anyway thanks for fix. I will test it when I get it.

-Technologov

comment:8 Changed 10 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 Changed 10 years ago by Technologov

Is there a test build to verify the fix ?

comment:10 Changed 10 years ago by klaus

3.2.10 of course.

comment:11 Changed 10 years ago by Technologov

  • Status changed from closed to reopened
  • Resolution fixed deleted

TuxRacer still fails with both VBox 3.2.12 and 4.0.0-BETA1/2.

-Technologov

comment:12 Changed 10 years ago by leonid

Could you check win xp version you have? If it's: Microsoft Windows XP Professional x64 Edition Version 2003 Service Pack 2

Then issue should be fixed for you in next beta.

comment:13 Changed 10 years ago by Technologov

It ןs: Microsoft Windows XP Professional x64 Edition Version 2003 Service Pack 1

-Technologov

comment:14 Changed 10 years ago by Technologov

Works w/ v4.0.0-BETA3

-Technologov

comment:15 Changed 10 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use