VirtualBox

Ticket #7057 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

disconnected host network on boot - removing vbox modules fixes the issue

Reported by: medigeek Owned by:
Priority: major Component: network
Version: VirtualBox 3.2.4 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I am not sure if this is a duplicate, sorry if it is.

Problem:

Host (my physical machine) has disconnected network (ethernet) during boot sometimes. If I reboot the machine, the networking is fine.

Description:

  • It seems random, does not happen always...
  • I tried to remove and reload r8169, but didn't help. The problem seems to disappear once I rmmod vbox-related kernel modules.

Attached files:

  • dmesg and several other "network debug" commands, showing the state of the network
  • commands (modprobe -r) I used to remove vbox-related kernel modules and reload my ethernet kernel module (r8169)

Notes:

I have noticed that there is a new version (3.2.4-62467), I will see if it happens with that install as well.

Using VirtualBox 3.2.4:

$ apt-cache policy virtualbox-3.2
virtualbox-3.2:
  Installed: 3.2.4-62431~Ubuntu~lucid
  Candidate: 3.2.4-62431~Ubuntu~lucid
  Version table:
 *** 3.2.4-62431~Ubuntu~lucid 0
        100 /var/lib/dpkg/status

Attachments

network_disconnected.zip Download (14.6 KB) - added by medigeek 4 years ago.
logfiles showing the disconnected state of the network

Change History

Changed 4 years ago by medigeek

logfiles showing the disconnected state of the network

comment:1 Changed 4 years ago by medigeek

Perhaps the priority of 10-vboxdrv.rules is too high?

$ ls -1 /etc/udev/rules.d/
10-vboxdrv.rules
70-persistent-cd.rules
70-persistent-net.rules
86-hpmud-hp_laserjet_1000.rules
86-hpmud-hp_laserjet_1005_series.rules
86-hpmud-hp_laserjet_1018.rules
86-hpmud-hp_laserjet_1020.rules
86-hpmud-hp_laserjet_p1005.rules
86-hpmud-hp_laserjet_p1006.rules
86-hpmud-hp_laserjet_p1007.rules
86-hpmud-hp_laserjet_p1008.rules
86-hpmud-hp_laserjet_p1505.rules
README

$ cat /etc/udev/rules.d/10-vboxdrv.rules 
KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
SUBSYSTEM=="usb_device", GROUP="vboxusers", MODE="0664"
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="vboxusers", MODE="0664"

$ cat /etc/udev/rules.d/70-persistent-net.rules
# This file maintains persistent names for network interfaces.
# See udev(7) for syntax.
#
# Entries are automatically added by the 75-persistent-net-generator.rules
# file; however you are also free to add your own entries.

# PCI device 0x10ec:0x8167 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:19:db:63:29:fc", 
ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

comment:2 Changed 4 years ago by michael

I believe that 70-* has a higher priority than 10-*. Since you are asking, did you try changing priorities and find that made a difference?

comment:3 Changed 4 years ago by medigeek

very good suggestion.. :) As soon as it happens again (since it doesn't happen on every boot), I'll try it and let you know!

comment:4 Changed 3 years ago by aleksey

Can you try with 4.0.2 and confirm the problem still exists?

comment:5 Changed 3 years ago by medigeek

Hi, I believe that the problem is resolved, thanks :)

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use