VirtualBox

Ticket #7022 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Slash (/) and Question Mark (?) key doesn't work in Ubuntu 10.04 guest vm in a 8.04 Ubuntu Host with a Brazilian Keyboard. -> fixed after 3.2.4

Reported by: __B__ Owned by:
Priority: minor Component: other
Version: VirtualBox 3.2.4 Keywords: keyboard, layout
Cc: Guest type: Linux
Host type: Linux

Description

I'm using an Ubuntu 8.04 as host, and an Ubuntu 10.04 as guest. The keys slash "/" and question mark "?" work in my host, but doesn't work in my guest.

I've tried to run xev and showkey -v in host and guest: it's detected in host, but the key isn't being detected in guest, not even a keycode is shown. Every other key is working.

I've tried to search for some related tickets, and found  #4957,  #599 and  #205, but no luck.

I'm using a HP keyboard, model HP KU-0316 (Brazilian Version).

Attachments

VBox.log Download (77.1 KB) - added by __B__ 4 years ago.
xmodmap.log Download (18.1 KB) - added by __B__ 4 years ago.
VBox.log.1 Download (73.0 KB) - added by pbrito81 4 years ago.

Change History

Changed 4 years ago by __B__

Changed 4 years ago by __B__

comment:1 Changed 4 years ago by __B__

I changed my keyboard, but the problem persists.

comment:2 Changed 4 years ago by michael

  • Summary changed from Slash (/) and Question Mark (?) key doesn't work in Ubuntu 10.04 guest vm in a 8.04 Ubuntu Host with a Brazilian Keyboard. to Slash (/) and Question Mark (?) key doesn't work in Ubuntu 10.04 guest vm in a 8.04 Ubuntu Host with a Brazilian Keyboard. -> fixed after 3.2.4

Fixed at the eleventh hour... it turns out that we were ignoring all X11 keycodes above 63, but the Brazilian "extra key" is one of the few important ones in that range.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:4 Changed 4 years ago by nbrouard

  • Status changed from closed to reopened
  • Resolution fixed deleted

Using latest 3.2.6 on Mac OSX, 3.2.6, when you change in Preferences -> Input and set your host key to None, the "a" key ("q" on French keyboard) doesn't work anymore on a WinXP or Linux Mandriva guest. On Linux even an xev doesn't react anymore.

When you set your hostkey back to Command Left (default) it works again. This is the first bug easy to reproduce.

The second limitation (bug?) is that when you set the default hostkey to Apple key and are using an external PC/Linux keyboard (not the MacBook Pro keyboard). Then, you can't use anymore the Alt Gr (right) key to access any composed key. Clicking on the Alt right key makes it permanent and you can't type any normal key. The only way that I found to exit that strange state is to click and hold the left Alt key and click on the right Alt key.

To resume, I can't change the default hostkey to "none" because of the first bug and can't keep the default because of the second bug (on non Apple keyboard).

comment:5 Changed 4 years ago by pbrito81

The slash ('/' and '?') key doesn't work for me on my Windows Xp guest, in a Ubuntu 10.04 host running VirtualVox 3.2.6. I'm using a Lenovo SL400, with a brazilian abnt2 keyboard.

comment:6 Changed 4 years ago by michael

nbrouard: you are probably best finding or creating a different ticket for that, as you are using an OS X host and this ticket concerns Linux and other X11 hosts (the keyboard handling is completely different for the two systems, and I am only familiar with the X11 variant).

pbrito81: could you please attach the log file from a run of a virtual machine that showed this problem? And just to be sure, did you tell the guest to use a Brazilian keyboard layout? The guest doesn't know about the host layout and has to be told separetely what sort of keyboard you are using.

Changed 4 years ago by pbrito81

comment:7 Changed 4 years ago by pbrito81

Here it is. There's a message about my keybord layout no being supported by VirtualBox in the very beggining of the log.

comment:8 Changed 4 years ago by pbrito81

The keyboard layout in the guest is correctly defined.

comment:9 Changed 4 years ago by pbrito81

Sorry, it seams to be a SL400/Windows bug. Found the solution here (in portuguese):

 http://info.abril.com.br/forum/viewtopic.php?f=198&t=7020

For those who dont't understand a word of portuguese, just create a binary entry named "Scancode Map" in the "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout" section containing the bytes "00 00 00 00 00 00 00 00 02 00 00 00 73 00 1d e0 00 00 00 00" and reboot.

Worked in W2k Pro and WXP Pro guests.

Curiously, as related by a workmate, VMWare Workstation guests does not have this issue.

Thanks to lucas.falconi

comment:10 Changed 4 years ago by michael

Ah, it looks like they changed the right control key on the Brazilian model to serve as the Brazilian extra key (I found a photo online which shows that the US model has a right control). Just out of interest, did you have to do any special configuration to make it work in Linux?

comment:11 Changed 4 years ago by pbrito81

Yes, i did. Not "so" special... By the way, what i did was selecting the right keyboard layout in System -> Preferences -> Keyboard -> Layout, field Model. In my case it was "IBM ThinkPad R60/T60/R61/T61".

If I select a generic keyboard model, the "?/" key works just like the right control key, as you said. I can even copy/past with ?+c and /+v!

comment:12 Changed 4 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed

In that case I will close this ticket again. Thanks for the updates.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use