VirtualBox

Ticket #6986 (closed defect: duplicate)

Opened 4 years ago

Last modified 3 years ago

Failed to access the USB subsystem

Reported by: saberman Owned by:
Priority: critical Component: USB
Version: VirtualBox 3.2.4 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Host: Windows 7 Ultimate x64

I upgraded to 3.2.4r62467 from 3.1.8. Now whenever I open the settings for a VM I get:

VirtualBox - Warning Failed to access the USB subsystem. Cound not load the Host USB Proxy Service (VERR_FILE_NOT_FOUND). The service might not be installed on the host compuer. Details Result Code E_FAIL (0x00004005) Component: Host Interface: IHost {35b004f4-7806-4009-bfa8-d1308adba7e5}

If I try to add a USB device filter the list is empty.

It appears that USB support is missing from 3.2.4 or at least failed to install.

Attachments

virtualbox-usb-issue.png Download (39.8 KB) - added by m00mba 4 years ago.
Screenshot of issue.
virtualbox-usb-still-an-issue.png Download (48.3 KB) - added by m00mba 4 years ago.

Change History

comment:1 Changed 4 years ago by m00mba

Same thing I just upgraded as well and I am getting the same message on Windows 7 Home

Changed 4 years ago by m00mba

Screenshot of issue.

comment:2 Changed 4 years ago by m00mba

Try getting the 3.2.4 image directly from virtualbox and repairing what you have. I downloaded one from them (virutalbox directly) and everything seems to be working. The one that did not work for me was from edgesuite.net

comment:3 Changed 4 years ago by saberman

I get all of my VirtualBox images directly from VirtualBox.org.

I tried the following:

  1. Running a repair using the installation package. This got rid of the error message and allowed me to edit the USB section of VM settings. Unfortunately, it did not make the USB device visible to the VM. (Yes. I rebooted everything a number of times.)
  2. Uninstalled VirtualBox 3.2.4 completely and then installed it again. Same results as (2).
  3. Uninstalled VirtualBox 3.2.4 completely and then installed 3.1.8. USB now working in VM.

Somewhere in the process of (1) and (2) I noticed a message that a device driver was being installed and then that the installation failed because the device was unplugged. It was for the VB USB device.

I also noticed that although the USB device was not visible in the guest in 3.2.4 it was removed from the host. That is having the computer manager -- device manager snapin open in the host I could see the USB device until I started the VM. Then it disappeared from the host. However, I could not see it in the computer manager -- device manager snapin in the guest. When I got 3.1.8 back in I could see it disappear from the host and appear in the guest.

Changed 4 years ago by m00mba

comment:4 Changed 4 years ago by m00mba

That is happening to as well saberman. So I agree we still have an issue here. Hopefully someone from Sun will fix this. Looks like I will be reverting back as well. Damn I hate buggy code.

comment:5 Changed 4 years ago by m00mba

Found a workaround until they fix this issue but its sort of cloogy. So after booting into my ubuntu vm I go to devices and then to floppy and pick Host Drive J which is my usb drive letter under windows. After that is selected go to Places and select Floppy Disk. All my files are showing up but I can only access some. Like I said its cloogy.

comment:6 Changed 4 years ago by whit

I'm having this problem with an upgrade to 3.2.6. Details are here:

 http://forums.virtualbox.org/viewtopic.php?f=6&t=18482&p=146155#p146155

comment:7 Changed 4 years ago by frank

  • Host type changed from other to Windows

comment:8 Changed 3 years ago by techno.scavenger

Happens on Windows 7 64 Prof host with VBOX 4.0.4 as well.

comment:9 Changed 3 years ago by allavbox

USB on 4.0.4 with guest additions was working fine then suddenly I started getting this error when opening Settings. Maybe coincidence but just previous to this I was trying to add raw disk access in Settings and failing in the mode of tickets 8428 & 8567. Immediately after 4 of those failures then whenever I open Settings I get this USB error. Host is Windows 7 H.P. sp1, guest is Debian variant Crunchbang 10.

comment:10 Changed 3 years ago by misha

FYI: We've reproduced this issue and currently working on solving it.

comment:11 Changed 3 years ago by allavbox

For me this USB error resolved itself as I was looking for a workaround for the v4.0.4 rawdisk registration issue. I editted .virtualbox.xml to register my vmdk file, started vbox, ignored the warning about inaccessible media, attached the raw disk. Still nogo so I de-attached the raw disk, closed vbox and restored the xml.

Now everything is back to normal. I believe this experience contains a clue to the USB error. [Host: Windows 7 H.P. sp1, guest: Crunchbang 10 (all 64bit)]

comment:12 Changed 3 years ago by virtualisator

same problem here: Result Code: E_FAIL (0x00004005) Component: HostInterface: IHost {35b004f4-7806-4009-bfa8-d1308adba7e5} Callee: IMachine {662c175e-a69d-40b8-a77a-1d719d0ab062}

extension pack is installen. win7 home 64bit, guest: winxp :)

virtualboxversion 4.0.6r71344

comment:13 Changed 3 years ago by virtualisator

addoN: this worked for me as well:  http://ubuntuforums.org/showthread.php?t=1738206

just start virtualbox as ADMINISTRATOR on Win7 (rightlick ....)

comment:14 Changed 3 years ago by virtualisator

:( no id did not. now i can "see" the usb root hub... but subsystem still fails

comment:15 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #5590.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use