VirtualBox

Ticket #698 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

VBoxManage snapshot command error => Fixed in 2.0.2

Reported by: laser Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.0 Keywords: VBoxMangae snapshot
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Calling VBoxManage results in a an error and print trace information on the console. More specifically, this error occurs when calling VBoxManage with the following command syntax:

VBoxManage snapshot machine_uuid showvminfo snapshot_uuid

The trace output is:

[!] FAILED calling display->get_Width(&xRes) at line 1137!
[!] Primary RC  = E_ACCESSDENIED (0x80070005) - General access denied error
[!] Full error info present: true , basic error info present: true 
[!] Result Code = E_ACCESSDENIED (0x80070005) - General access denied error
[!] Text        = The console is not powered up
[!] Component   = Display, Interface: IDisplay, {09789f63-4525-48e5-a5e41080453b0eab}
[!] Callee      = IDisplay, {09789f63-4525-48e5-a5e4-1080453b0eab}

I have attached a screenshot of VirtualBox GUI showing machine snapshots, together with a log of the output from "VBoxManage showvminfo machine_uuid" to give an overview of my environment. However, the error is demonstated in the attached file "snapshot.txt".

A related issue is that the snapshot named "Running snapshot" (UUID: 120558e6-1526-4df3-b713-fd5d375bc47b) was created whilst the virtual machine was powered on. However, the output shown in "snapshot.txt" indicates that the machine was powered off when this snapshot was taken. Is this as intended? If so, how can a shell tool determine from parsing the output from VBoxManage whether a particular snapshot was taken when the virtual machine was powered on or powered off.

Kind regards,

laser

Attachments

vb_snapshot.tif Download (65.9 KB) - added by laser 7 years ago.
Screen capture showing VB snapshots
vb_snapshot.gif Download (21.1 KB) - added by laser 7 years ago.
Screen capture showing VB snapshots (GIF format)
vms.txt Download (1.5 KB) - added by laser 7 years ago.
VBoxManage showvminfo machine_uuid
snapshot.txt Download (1.6 KB) - added by laser 7 years ago.
VBoxManage snapshot machine_uuid showvminfo snapshot_uuid

Change History

Changed 7 years ago by laser

Screen capture showing VB snapshots

Changed 7 years ago by laser

Screen capture showing VB snapshots (GIF format)

Changed 7 years ago by laser

VBoxManage showvminfo machine_uuid

Changed 7 years ago by laser

VBoxManage snapshot machine_uuid showvminfo snapshot_uuid

comment:1 Changed 7 years ago by laser

System configuration... Host: WinXP 32; Guest: WinXP 32; VirtualBox v1.50; CPU: AMD Athlon 64 X2;

comment:2 Changed 7 years ago by frank

  • Description modified (diff)

comment:3 Changed 6 years ago by frank

  • Summary changed from VBoxManage snapshot command error to VBoxManage snapshot command error => Fixed in 2.0.2

comment:4 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use