VirtualBox

Ticket #6937 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Mouse-over functionality in Linux/X.Org guest failing and link to dri driver missing -> fixed in SVN

Reported by: thomasd Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.2.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I run an up-to-date Arch Linux x86_64 as guest using their [testing] repository, which installs X.org Server 1.8.

I seem to have no mouse-over effects at all inside the guest. My window manager (wmii) normally has sloppy focus, i.e., focus follows mouse, but I have to click inside the windows to focus them. Also, in Firefox, menus that are based on the mouse-over effect on some sites do not work inside Virtualbox, I have to click the menus to open them.

Visit dpreview.com as an example for such a website. The upper menu is mouse-over. If I hover over "Reviews" nothing happens. If I click on "Reviews", two things happen: The drop-down menu opens and at the same time the link that "Reviews" includes is followed. So effectively, I cannot make use of the drop-down menu.

Another thing, don't know if it is related: If I mark text in any application, being Firefox or xterm or anything else, I see the marking only if I release the mouse button, not while marking the text.

Someone on this thread  http://forums.virtualbox.org/viewtopic.php?f=3&t=31798&start=0 suggested to hold down a key while moving the mouse. And indeed, my window manager shows mouse-follows-focus again and browsing is also fine when holding the left Ctrl button while moving the mouse.

Attachments

xorg.conf Download (497 bytes) - added by thomasd 4 years ago.
Xorg.0.log Download (25.6 KB) - added by thomasd 4 years ago.

Change History

comment:1 Changed 4 years ago by michael

This normally happens when the vboxmouse mouse driver is associated with /dev/input/mice or something similar in xorg.conf instead of with /dev/vboxguest.

Do you have an /etc/X11/xorg.conf file in the guest, and if so did you create it yourself? And can you attach /var/log/Xorg.0.log and xorg.conf if any to this ticket?

Changed 4 years ago by thomasd

Changed 4 years ago by thomasd

comment:2 Changed 4 years ago by thomasd

You are right, substituting /dev/input/mice by /dev/vboxguest fixed this. Thanks. I am attaching the files which let it fail, just in case.

I noticed another issue in the Xorg.0.log: The file /usr/lib/xorg/modules/dri/vboxvideo_dri.so is missing. Should I open a separate ticket for this?

comment:3 Changed 4 years ago by michael

  • Summary changed from no mouse-over functionality with X.org server 1.8 in guest to Mouse-over functionality in Linux/X.Org guest failing and link to dri driver missing

No need for a new ticket. To fix this manually, create the missing file as a symlink to /usr/lib/VBoxOGL.so.

comment:4 Changed 4 years ago by michael

  • Summary changed from Mouse-over functionality in Linux/X.Org guest failing and link to dri driver missing to Mouse-over functionality in Linux/X.Org guest failing and link to dri driver missing -> fixed in SVN

This has been fixed in the development code.

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use