VirtualBox

Ticket #6918 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Memory leak 3.2.2 -> fixed in SVN.

Reported by: tholin Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.2.10 Keywords: memory leak
Cc: thomas.lindroth@… Guest type: other
Host type: other

Description

Since upgrading to 3.2.0 I started experiencing a memory leak. I'm using a windows xp guest on a linux host. The guest got 512 mb ram but after a few hours of usage the VM use a few gb of ram. Restarting the VM frees the memory. The problem also exists on 3.2.2.

I'm using the VM for file sharing so it use the network and shared folder a lot. I'm using the intel desktop NIC in NAT mode.

I've attached the log of a typical run where the VM started using so much ram I had to restart it.

Attachments

VBox.log.1 Download (66.6 KB) - added by tholin 4 years ago.
VBox.log Download (143.6 KB) - added by greerga 4 years ago.
Ubuntu 10.04 host (3.2.4 VirtualBox), Windows XP guest (3.2.4 guest additions), running iTunes sync to iPhone
r66677.patch Download (1.3 KB) - added by Hachiman 4 years ago.

Change History

Changed 4 years ago by tholin

comment:1 Changed 4 years ago by hugwijst

I'm having the same issue using Ubuntu 10.04 x86 as host and Windows XP Pro as guest on 3.2.2. I'm doing a lot of reading/writing to a shared folder and I'm using 2 usb-devices.

comment:2 follow-up: ↓ 5 Changed 4 years ago by ming_zym

I have the seem problem with my gentoo host and windows XP guest, with virtualbox version 3.2.0 to 3.2.4, XP with SP3 and latest patch applied.

the memory rising too fast, at speed about 1MB/5s, that is crazy.

comment:3 Changed 4 years ago by frank

Still trying to reproduce. What is executed in your guest?

comment:4 Changed 4 years ago by tholin

The guest is running a Japanese file sharing app named "share". It a fairly standard p2p app.

I've looked at the memory usage under different usage patterns and I believe the memory only increase when network data is sent. Receiving packages and accessing the shared folder doesn't seem to increase the memory usage.

comment:5 in reply to: ↑ 2 Changed 4 years ago by Hachiman

Replying to ming_zym:

I have the seem problem with my gentoo host and windows XP guest, with virtualbox version 3.2.0 to 3.2.4, XP with SP3 and latest patch applied.

the memory rising too fast, at speed about 1MB/5s, that is crazy.

Could you please uninstall GA and replace VBox Shared Folders with SMB shares (general network shares)? Will it change the memory consumption?

Changed 4 years ago by greerga

Ubuntu 10.04 host (3.2.4 VirtualBox), Windows XP guest (3.2.4 guest additions), running iTunes sync to iPhone

comment:6 Changed 4 years ago by greerga

Same problem on mine:

Host: Ubuntu 10.04 (2.6.32-22-generic SMP) with VirtualBox 3.2.4 (3.2.0 also bad). CPU: Core i7 920. Guest: Windows XP (3.2.4 guest additions) Activity: iTunes sync to iPhone with media library in a shared folder

Guest memory explodes to 3.9GB before it stalls in a swap storm. (I have 6GB total.) The 1MB/s is about accurate.

3.1.8 works just fine.

comment:7 Changed 4 years ago by greerga

Host at 3.1.8 with guest having 3.2.4 additions also works fine.

(Not the best configuration to run admittedly, but I wanted to see whether it was the guest addition's fault.)

comment:8 Changed 4 years ago by frank

Still trying to reproduce (without requiring iTunes...)

comment:9 Changed 4 years ago by frank

We fixed some minor leaks in the 3.2.6 Beta 1. Any chance to check if you still observe the memory leak with this Beta?

comment:10 Changed 4 years ago by greerga

iOS4 release means my runs aren't exactly the same as before, but I have yet to get uncontrolled memory allocation during the OS update or the subsequent 13GB of transfers back to the phone afterward to restore it, so it is probably fixed.

comment:11 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback. Please reopen if the problem persists with VBox 3.2.6.

comment:12 Changed 4 years ago by tholin

  • Status changed from closed to reopened
  • Resolution fixed deleted

I've been out traveling so I didn't have time to test the new version until now. I tried 3.2.6 now and I still experience the same problem. I'll try to set up a samba share for debugging but I have little time right now so it could take a few days.

comment:13 Changed 4 years ago by yareckon

I believe this is also affecting me. Here is my post over in #6472

comment:14 Changed 4 years ago by frank

Everybody who encounters this problem: Is RDP involved, that is, is the RDP server of the VM enabled?

comment:15 Changed 4 years ago by faulebutter

I experience the same problem with VB 3.2.8 PUEL on F13 host with heavy network load (VMDK on an NFS share and VRDP session with video running). The VM gets killed by kernel due to memory overallocation. (I've also posted this on forums:  http://forums.virtualbox.org/viewtopic.php?f=7&t=34702&p=155557#p155557).

comment:16 Changed 4 years ago by tholin

I tested 3.2.10_OSE today and I still have the same problem. I tried to uninstall the guest additions and used a samba share instead of the shared folder but I still got the leak. I don't use RDP so I don't think this problem is related to RDP. Does the open source edition even have the RDP server?

Most of the traffic in the guest go through a VPN tunnel and it uses UDP packages to tunnel the TCP connections. I don't get so much memory leak if I disable to VPN so maybe only UDP/ICMP packages cases the leaks.

The 3.1.8 kernel modules no longer compile with resent kernels so it would be good if someone could look at this.

comment:17 Changed 4 years ago by tholin

I did some debugging and I'm now certain that outgoing UDP packages and only outgoing UDP packages cause the memory leak. Below are some easy steps to reproduce the bug.

  1. Create a VM and install Windows XP (other OS should also work)
  2. Set the network to NAT using any of the Intel or PCnet cards (I haven't tested the virtio card)
  3. Download and start TPTEST v3.12 or any other UDP generating test tool. (TPTEST is small and doesn't require installation)  http://www.bredbandskollen.se/download/tp312swe.exe
  4. Go to arkiv->advance mode.
  5. Pick a server, tick the Send box and input some crazy values for the UDP test. I use 1000pack/sec, 1000B/pack and 30sec test time.
  6. Start the UDP test and watch the VM memory usage increase.

Part of TPTEST:s interface is written in Swedish but that shouldn't be a problem.
Running the TCP send/receive or UDP receive test doesn't increase the memory usage in any significant way. I'm willing to test any debug patches to get to the bottom of this.

Changed 4 years ago by Hachiman

comment:18 follow-up: ↓ 19 Changed 4 years ago by Hachiman

Could you please check if attached patch fixes issue for you?

comment:19 in reply to: ↑ 18 Changed 4 years ago by tholin

Replying to Hachiman:

Could you please check if attached patch fixes issue for you?

YES! This patch fix the problem. Thanks.

comment:20 Changed 4 years ago by Hachiman

Thanks for feedback.

comment:21 Changed 4 years ago by Hachiman

  • Version changed from VirtualBox 3.2.2 to VirtualBox 3.2.10
  • Summary changed from Memory leak 3.2.2 to Memory leak 3.2.2 -> fixed in SVN.

comment:22 Changed 4 years ago by Hachiman

  • Component changed from other to network/NAT

comment:23 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed in VBox 3.2.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use