VirtualBox

Ticket #6898 (closed defect: fixed)

Opened 4 years ago

Last modified 19 months ago

3.2.x results in system hangs / BSODs on XP x64 host

Reported by: Kurt_Aust Owned by:
Priority: blocker Component: other
Version: VirtualBox 3.2.2 Keywords: Hang BSOD
Cc: Guest type: Windows
Host type: Windows

Description (last modified by frank) (diff)

Initially I thought the 3.2.x series was great, finally the guest hangs/BSODs I was getting with the 3.1.x series were no more. Unfortunately I can't consider trading them in for host hangs/BSODs as a good trade-off.

The hangs/BSODs seem fairly random which made diagnosing the offending application rather difficult, I did so by reverting/uninstalling applications until host stability returned.

I had just gone several days after uninstalling 3.2.0 without further incident when 3.2.2 was released, within an hour of installing it I copped a BSOD.

My best guess is that it has something to do with the network driver as internet facing applications were the ones to hang (Seamonkey, Vuze, Skype) and it does so even if the VirtualBox application is not running.

Specs: Intel Q9450, Gigabyte EP45-DS3R, 8GB DDR2-800, 4* 1TB RAID 10 (ICH10R)

Comodo Firewall 3.14.130099.587, Avast AV (still hangs if uninstalled though), Spybot S&D

So for now I've reverted back to 3.0.12 (the last version without issues).

Attachments

Mini060410-01.dmp Download (172.0 KB) - added by Kurt_Aust 4 years ago.
VBox.log Download (55.8 KB) - added by Kurt_Aust 4 years ago.
VBox.2.log Download (72.0 KB) - added by mgpetryk 4 years ago.
VBox.3.log Download (41.0 KB) - added by mgpetryk 4 years ago.
Stable 3.0.14 VM
VBox.4.log Download (55.8 KB) - added by Kurt_Aust 4 years ago.
Mini060910-01.dmp Download (172.0 KB) - added by Kurt_Aust 4 years ago.
VBox.log.1 Download (51.0 KB) - added by iNdefiNite 4 years ago.
VBox logfile of the latest host OS hang with XP64

Change History

comment:1 Changed 4 years ago by misha

Please attach a  minidump for the system crash (BSOD) you see.

Changed 4 years ago by Kurt_Aust

comment:2 Changed 4 years ago by Kurt_Aust

Done, I thought I'd have to do that but I couldn't remember where to find it. Perhaps that information should be added to the front page of the bug tracker, for instance:

# Try to clearly describe the bug and ways to reproduce it. Attach your VirtualBox VM session log file (VBox.log) to the ticket! This file includes a lot of useful information and saves us time asking you for it. If you are using the main VirtualBox user interface you can access the log files using the "Show Log..." entry in the "Machine" menu.

# If your problem involves a Microsoft Windows system crash (BSOD, either host or guest), please include  the generated minidump file.

comment:3 Changed 4 years ago by frank

I would still like to see a VBox.log file of such a VM session to see your VM config.

Changed 4 years ago by Kurt_Aust

comment:4 Changed 4 years ago by Kurt_Aust

Added log file, please note that the guest had a BSOD in the midst of installing, I reset the VM and it continued for about 30 minutes before taking the host down.

comment:5 Changed 4 years ago by misha

Just to make the things clear: am I correct that

  1. You get host bsod (described in attached minidump) only when running some VM(s) with bridged networking?
  2. You get net application hang (Seamonkey, Vuze, Skype) when no VMs have ever been run since the host system boot?
  3. You did not have any of the above issues before the 3.2.0

Thanks

comment:6 Changed 4 years ago by Kurt_Aust

1: Correct, although it only happened once, specifically the first time I tried 3.2.2 to see if the problems I had been having with 3.2.0 had been resolved. I only run one VM at a time.

2: Correct.

3: Correct, though as noted in the original post, I found the 3.1.x series unusable due to guest hangs/BSODs.

comment:7 Changed 4 years ago by mhanor

the minidump points to an Comodo Firewall component (a driver named inspect.sys)

you could use windbg (search for Debugging Tools for Windows) and attach it to a hanging app, then run !analyze -v -hang , and attach here the windbg output

Changed 4 years ago by mgpetryk

comment:8 follow-up: ↓ 10 Changed 4 years ago by mgpetryk

I have also seen many hangs using 3.2.2 on a Win 7/64 host with a Win 7/86 guest. Typically the VM would run for several minutes, then just become unresponsive. Switching to 3.0.14 has fixed the hangs.

Changed 4 years ago by mgpetryk

Stable 3.0.14 VM

comment:9 Changed 4 years ago by mgpetryk

Previous attachment (VBox.2.log) was from version 3.2.2

I am now attaching a log from my stable 3.0.14

comment:10 in reply to: ↑ 8 Changed 4 years ago by mhanor

Replying to mgpetryk: Your problem is not the same with Kurt_Aust's. He experienced a host BSOD and host applications hang.

comment:11 Changed 4 years ago by Kurt_Aust

I've installed 3.2.4 and so far had no hangs (touch wood), perhaps my problems were related to bug 6855:  http://www.virtualbox.org/ticket/6855

Hopefully this case can be considered closed, but as the hangs were seemingly random it will be at least several days before I can be truly confident that the problem has been licked.

comment:12 Changed 4 years ago by mgpetryk

I have also installed 3.2.4 and am no longer seeing my hang condition. Thank you!!

comment:13 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

In that case I will close this ticket. Thanks for the feedback. Please reopen if necessary.

comment:14 Changed 4 years ago by Kurt_Aust

  • Status changed from closed to reopened
  • Resolution fixed deleted

No such luck, another host BSOD while running VB 3.2.4 (no hangs though), reverting back to 3.0.14, log and minidump attached.

Changed 4 years ago by Kurt_Aust

comment:15 Changed 4 years ago by sandervl73

The dump file appears corrupt. Windbg can't load it.

Changed 4 years ago by Kurt_Aust

comment:16 Changed 4 years ago by Kurt_Aust

minidump re-uploaded

comment:17 Changed 4 years ago by frank

Minidump was re-uploaded.

comment:18 Changed 4 years ago by sandervl73

Same thing (downloaded several times). Looks like the minidump wasn't created correctly.

comment:19 Changed 4 years ago by iNdefiNite

I'm having such an issue with a running VM. Trying to figure out, if it's a fault of recently "patched" host-only and bridged network drivers by running the VM on NAT. Will report later.

comment:20 follow-up: ↓ 21 Changed 4 years ago by iNdefiNite

It's been 6 hours since I've started testing without bridged networking and the machine still runs without a hang or bsod. My bet is indeed the network driver. Not the first time there have been issues with it after "fixing".

comment:21 in reply to: ↑ 20 Changed 4 years ago by misha

Replying to iNdefiNite: Could you attach a  minidump for the crashe you were seeing. Without it we won't be able to help.

comment:22 Changed 4 years ago by iNdefiNite

Not sure if I'll be able to support, as my system partition is TrueCrypted and isn't able to save minidumps upon crash.

comment:23 Changed 4 years ago by Kurt_Aust

I tried using 3.2.6 for a while and had no problems with host instability, perhaps it was related to bug 6166.

However guests were still unstable so once again I've reverted back to 3.0.14

Changed 4 years ago by iNdefiNite

VBox logfile of the latest host OS hang with XP64

comment:24 Changed 4 years ago by iNdefiNite

Ok, switched to 3.2.6 and this night I've noticed another host hang, despite having my VM running on NAT.

comment:25 Changed 19 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.1.22.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use