VirtualBox

Ticket #6875 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Win7 Pro host BSOD when trying to start ubuntu guest in VB 3.2.2 -> Install fixed 3.2.2 Windows package

Reported by: antonmos Owned by:
Priority: blocker Component: other
Version: VirtualBox 3.2.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

Potentially caused by Host Only adapter as noted in this  forum topic

BSOD Text: STOP: 0x0000008E (0Xc0000005,0xA8D737CB,0xA926335E8,0X0000000) VMMR0.r0 - address A8D737CB base at A8D2F0000, DateStamp 4c066d60

System Log: The computer has rebooted from a bugcheck. The bugcheck was: 0x000000d1 (0x00000014, 0x00000002, 0x00000000, 0xa9e707cb). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 060210-22698-01.

Attachments

log1.log Download (930 bytes) - added by antonmos 4 years ago.
VBox.log Download (34.8 KB) - added by kissson 4 years ago.
060310-27066-01.dmp Download (269.1 KB) - added by Leak 4 years ago.
Kernel minidump of the crash (Win7 x64 Ultimate)

Change History

Changed 4 years ago by antonmos

comment:1 Changed 4 years ago by longshow

the same as windows xp sp2 guest,blue screen.

Changed 4 years ago by kissson

comment:2 Changed 4 years ago by kidault

same problem host: win 7 pro guest: xp sp2 home uncheck vt-x don't help

not affect dos 6.22 guest.

comment:3 Changed 4 years ago by kidault

information given by windows after reboot 问题签名:

问题事件名称: BlueScreen OS 版本: 6.1.7600.2.0.0.256.48 区域设置 ID: 2052

有关该问题的其他信息:

BCCode: d1 BCP1: 00000014 BCP2: 00000002 BCP3: 00000000 BCP4: AB0817CB OS Version: 6_1_7600 Service Pack: 0_0 Product: 256_1

comment:4 Changed 4 years ago by michael-ch

same problem: Host: Win 7 Pro Guest: OpenSuse 11.2

comment:5 Changed 4 years ago by schiegl

same problem: Host: Win 7 Pro (64 bit), Guest: FreeBSD 32bit with 2 NICs - Solaris 10 with one NIC works just fine - suspect: 32bit/64bit or more than one NIC.

No host-adapter in use.

comment:6 Changed 4 years ago by thomasd

I get something similar, but no BSOD, the screen just gets blank and the host resets and reboots.

  • Host: Windows 7 Home Premium 64bit
  • Guest: Arch Linux x86_64
  • two Network adapters: NAT and Host-Only.
  • VT-x and Nested paging on.

comment:7 Changed 4 years ago by frank

  • Priority changed from major to critical
  • Host type changed from other to Windows

Changed 4 years ago by Leak

Kernel minidump of the crash (Win7 x64 Ultimate)

comment:8 Changed 4 years ago by Leak

Same here - after upgrading, starting my Debian VM immediately caused a BSOD without even the BIOS logo showing up or the VM log file ever making it to the disk.

I've uploaded the minidump Windows (Win7 x64 Ultimate on a Core i7-860) wrote before completely croaking...

comment:9 Changed 4 years ago by sandervl73

  • Priority changed from critical to blocker

Are all of you using host-only or host-interface networking? If so, then please try using (only) NAT for a test run. Thanks.

comment:10 Changed 4 years ago by Leak

Yes, host-only networking is the culprit in my case; as soon as I disabled the NIC using it in the VM settings the VM booted without problems - except for me not being able to SSH into it, of course... ;)

comment:11 Changed 4 years ago by KenHagan

I'm seeing something very similar with a Server 2003 sp2 host (and XP sp3 guest). The host CPU is an Athlon 64x2, but the host OS is 32-bit flavour.

If I disable the host-only adapter (I also have a bridged one in this VM) then everything is fine. If I re-enable the adapter (with or without the bridged one alongside) then shortly after the VM finished its boot sequence (so perhaps when the guest DHCP client starts sniffing on the host-only network) the host system spontaneously reboots. (No BSOD, but Windows did send off a WER report upon rebooting the host.)

Previously using 3.1.8 without incident, upgraded to 3.2.2 this morning (and sticking with it because I can live without the host-only network for a while).

comment:12 Changed 4 years ago by thomasd

Is it safe to remove the Host-only adapter temporarily or does the hardware address change on re-creation?

comment:13 Changed 4 years ago by sandervl73

We've found the problem and will rebuild the Windows package asap (today). Sorry for the inconvenience and thanks for the quick reports!

comment:14 Changed 4 years ago by KenHagan

@thomasd: The hardware address is remembered if you simply disable the adapter (as I have done) rather than completely remove it. (You can see it still in the XML file after you've unticked the "enable" box.)

@sandervl73: Crikey! That's fast. Feel free to be quite smug about that.

comment:15 Changed 4 years ago by frank

Upload completed. Please download the  fixed package (bad build: 62298, fixed build: 62321)!

comment:16 Changed 4 years ago by frank

  • Summary changed from Win7 Pro host BSOD when trying to start ubuntu guest in VB 3.2.2 to Win7 host BSOD when starting guest in VBox 3.2.2 => Install fixed 3.2.2 Windows package

comment:17 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Win7 host BSOD when starting guest in VBox 3.2.2 => Install fixed 3.2.2 Windows package to Win7 Pro host BSOD when trying to start ubuntu guest in VB 3.2.2

comment:18 Changed 4 years ago by sandervl73

  • Summary changed from Win7 Pro host BSOD when trying to start ubuntu guest in VB 3.2.2 to Win7 Pro host BSOD when trying to start ubuntu guest in VB 3.2.2 -> Install fixed 3.2.2 Windows package

comment:19 Changed 4 years ago by schiegl

fix confirmed. thanks for the quick update!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use