VirtualBox

Ticket #6865 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

part of VM BIOS is overwritten during boot

Reported by: MarkCranness Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.0 Keywords: BIOS
Cc: Guest type: other
Host type: Windows

Description

VirtualBox contains a 0x10000 (65536) byte BIOS used as the VM boots. At some point after VM boot, part of the BIOS (bytes F000:0F00 thru 0FFF) are overwritten and corrupted.

That range corresponds to part of function keyboard_init(), which apparently is not yet corrupted during POST, but at some later point is overwritten, and for the default BIOS this overwrite (apparently) causes no problems.

But if a user uses a custom BIOS file, this overwrite may cause problems.

Change History

comment:1 Changed 4 years ago by frank

Cannot reproduce, maybe this problem depends on the configuration. Could you attach a VBox.log file and tell something about your guest? Booting a Linux guest and reading the BIOS from /dev/mem gives the exact same image which was generated during compilation.

comment:2 Changed 4 years ago by MarkCranness

I can't reproduce either... Sorry, what must have happened was I mangled the steps to extract the BIOS somehow, while trying to get the last 0x100 bytes. Please close.

comment:3 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use