VirtualBox

Ticket #6848 (reopened defect)

Opened 4 years ago

Last modified 3 years ago

OpenGL / Linux Guest not working since 3.1.8 -> Fixed in SVN

Reported by: topse Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.2.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

Hi, I have the following behaviour on a Win7-64 Host with an (latest) Ubuntu-10.x- (32Bit)Guest:

With the VBox Version 3.1.6 I could start most OpenGL-Applications only some were not working (for example all Applications based on OGRE3D-Framework did not work).

Since I updated to 3.1.8 and later (3.2.0), I cannot run any OpenGL-Application, always getting an error like:

OpenGL Warning: XGetVisualInfo returned 0 visuals for 0x950fd60 Segmentation fault

For example an application which worked with 3.1.6 were the bullet-demo-applications ( http://code.google.com/p/bullet/downloads/list,  http://code.google.com/p/bullet/downloads/detail?name=bullet-2.76.zip&can=2&q=) which is now not working anymore.

I have attached the Log-File.

Best Regards,

Tobias

Attachments

VBox.log Download (71.0 KB) - added by topse 4 years ago.
VBox-Logfile
crlog.txt Download (1.4 KB) - added by topse 4 years ago.
CR_DEBUG_FILE
bug.c Download (462 bytes) - added by aegnor 3 years ago.
crlog.2.txt Download (2.6 KB) - added by aegnor 3 years ago.
bug2.c Download (736 bytes) - added by aegnor 3 years ago.
crlog2.txt Download (6.3 KB) - added by aegnor 3 years ago.
crlog.3.txt Download (2.5 KB) - added by Abhijit 3 years ago.
Opengl crash log

Change History

Changed 4 years ago by topse

VBox-Logfile

comment:1 Changed 4 years ago by leonid

Could you run your guest app with export CR_DEBUG_FILE=crlog.txt and attack the log please.

Changed 4 years ago by topse

CR_DEBUG_FILE

comment:2 Changed 4 years ago by topse

Here it comes... cool feature this debug log...

comment:3 Changed 3 years ago by eteq

I'm encountering this problem in 3.2.10, with a Win7-64 host and Ubuntu 10.10 - 64... Any progress based on the older submission?

comment:4 Changed 3 years ago by leonid

  • Summary changed from OpenGL / Linux Guest not working since 3.1.8 to OpenGL / Linux Guest not working since 3.1.8 -> Fixed in SVN

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix contained in VBox 3.2.12.

comment:6 Changed 3 years ago by aegnor

  • Status changed from closed to reopened
  • Resolution fixed deleted

Bug exists in ubuntu 10.10 guest, Windows 6 host, VirtualBox 4.0.4. Attached guest program that triggers the bug and log output.

Oddly enough, adding a call to glXQueryVersion prevents the segfault (found this in ticket #8293). bug2.c includes that call; crlog2.txt is the log from that run.

Changed 3 years ago by aegnor

Changed 3 years ago by aegnor

Changed 3 years ago by aegnor

Changed 3 years ago by aegnor

comment:7 Changed 3 years ago by Abhijit

I have the same problem, Windows 7 host 64 bit, and fedora 15 guest, was trying to run the bullet RagDollDemo example, logfile attached

Changed 3 years ago by Abhijit

Opengl crash log

comment:8 Changed 3 years ago by RyanMentley

I am having this issue on 4.1.4 with a simple GLUT application on Ubuntu 11.04. It works if LIBGL_ALWAYS_INDIRECT=1 is set, however. I can provide whatever logs are needed.

3D acceleration is enabled in the settings, 2D is not. The current version of the additions is installed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use