VirtualBox

Ticket #6843 (closed enhancement: duplicate)

Opened 4 years ago

Last modified 3 years ago

Boot from USB device

Reported by: tlhonmey Owned by:
Priority: minor Component: USB
Version: VirtualBox 3.2.0 Keywords: BIOS
Cc: Guest type: other
Host type: other

Description

Since it is possible to attach USB devices to the guest in "pass through" mode, it would be quite useful (to me at least) to be able to boot the guest from such a device. It would allow for easy creation/testing of bootable USB devices for a variety of purposes. Currently, in order to do this kind of thing, I have to use the raw disk option, which doesn't always seem compatible with reformatting the disk, and makes it so that the guest OS doesn't realise that it's on a thumb drive, so any optimisations it may have for such circumstances are lost.

Change History

comment:1 Changed 4 years ago by Technologov

A related wish found: #2230

-Technologov

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2935.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use