VirtualBox

Ticket #6835 (closed defect: fixed)

Opened 4 years ago

Last modified 5 months ago

invalid rdmsr instructions do not cause a #GP fault in the guest

Reported by: camptatopenmarsdotcom Owned by:
Priority: minor Component: VMM
Version: VirtualBox 3.1.8 Keywords: MSR
Cc: Guest type: Windows
Host type: Windows

Description

executing rdmsr with explicitly or implicitly invalid MSR values does not cause a #GP fault to be reflected to the guest. I primarily have noticed this within a device driver running under windows 2008r2, but this seems to be a more fundamental feature of the architecture that should not have an OS dependency.

Change History

comment:1 Changed 4 years ago by sandervl73

  • Priority changed from major to minor
  • Component changed from VMM/HWACCM to VMM

True, but that's not likely to be the cause of any real world problems. Generating a #GP would cause an infinite amount of problems as many different CPU models support even more different MSRs.

comment:2 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The behavior was changed in VBox 4.3.x.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use