VirtualBox

Ticket #6809 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

Settings dialog improperly complains about missing Name field after adding ISO image (KDE hosts) => Fixed in SVN

Reported by: DanielKulesz Owned by:
Component: GUI Version: VirtualBox 4.0.8
Keywords: Cc:
Guest type: other Host type: other

Description

Steps to reproduce:

  • Create a new virtual machine (in my case a standard Linux VM, with created new disk image)
  • Enter settings dialog and enter storage settings
  • Open the virtual media manager with the icon besides CD/DVD device
  • Add the desired ISO

Now you return to the settings dialog, with the ISO selected. I would expect now to be able to click "ok" in this dialog to close the session. Instead, the dialog complains about

"The value of the Name field on the General page is not complete" (see attached screenshot)

Workaround: Close the dialog with cancel, re-enter it, choose the proper ISO and now you can click ok without VirtualBox complaining.

Attachments

bug.png Download (44.8 KB) - added by DanielKulesz 11 years ago.
screenshot
snapshot50.png Download (51.8 KB) - added by Roejames12 11 years ago.
Oversized icons..
vbox-bug.jpg Download (36.6 KB) - added by ailie 10 years ago.

Change History

Changed 11 years ago by DanielKulesz

screenshot

comment:1 Changed 11 years ago by phobeus

Confirming this bug for 3.2.6 and it exist since some versions now. It is actually one of the most anonying issues for VirtualBox since everyone who is creating a new VM to test a new iso will find it. First I thought that it might be just related to the German version, but the screen shoot of the former post shows, that also english is affected.

comment:2 Changed 11 years ago by DanielKulesz

Yes - it's sad to see how this really nasty bug - reported over 2 months ago - can stay so long untouched / not prioritized / not tagged for a release.

comment:3 Changed 11 years ago by frank

I believe that this bug is very annoying but the problem is that we cannot reproduce this bug in a deterministic way.

comment:4 Changed 11 years ago by frank

To be more specific: Your instructions to reproduce the problem work only sometimes. But perhaps sometimes is enough to fix the problem...

comment:5 Changed 11 years ago by frank

Can both of you confirm that your are using a KDE host?

comment:6 Changed 11 years ago by DanielKulesz

Yes, I am using a KDE Host.

comment:7 Changed 11 years ago by phobeus

I confirm also, that I am using KDE 4.5 with Oxygen style.

comment:8 Changed 11 years ago by frank

  • Summary changed from Settings dialog improperly complains about missing Name field after adding ISO image to Settings dialog improperly complains about missing Name field after adding ISO image (KDE hosts)

comment:9 Changed 11 years ago by Roejames12

Confirmed on Ubuntu 10.04 x86_64 using KDE 4.4.2. For me, this bug is very reproducible, and I can reproduce it every single time using these steps:

1) Start VirtualBox by opening the GUI manager
2) Select a virtual machine from the list (or create a new one first and select it)
3) Click settings
4) Go to ANY area of the program that allows you to select files/directory to share/new hard drive images, iso, etc
5) Click on the browse button, select a hard drive image/iso etc.
6) Invalid Name field error ensues
7) Close VirtualBox, and repeat steps 1-6 again

comment:10 Changed 11 years ago by frank

Thank you for these instructions.

comment:11 Changed 11 years ago by frank

  • Summary changed from Settings dialog improperly complains about missing Name field after adding ISO image (KDE hosts) to Settings dialog improperly complains about missing Name field after adding ISO image (KDE hosts) => Fixed in SVN

It turned out that this was a problem with newer Qt versions on KDE hosts. In that case, native KDE file dialogs will be used and there are reports that this often does not work, see for instance  here. The problem arises only for newer Linux distributions. The next maintenance release will contain a fix which will disable native file dialogs on KDE hosts.

comment:12 Changed 11 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:13 Changed 11 years ago by DanielKulesz

I am happy to confirm that I was not able to reproduce the problem in the latest maintenance release (3.2.8).

Thanks a lot for addressing this issue!

comment:14 Changed 11 years ago by frank

Thanks for the feedback!

comment:15 Changed 11 years ago by Roejames12

Not to be ungrateful, but I do have a slight problem with the new file dialog.

First of all, let me explain, the problem IS fixed :), there was just one side effect for me! The icons I see are oversized, way too far, and it's driving me crazy.

I'm using the KDE Bespin style (latest from SVN), and a custom imageset (ask for the imageset if you want it, I'm the only one that "has it").

I wasn't sure whether I should reopen this, so I left it as closed.

Changed 11 years ago by Roejames12

Oversized icons..

Changed 10 years ago by ailie

comment:16 Changed 10 years ago by ailie

  • Status changed from closed to reopened
  • Resolution fixed deleted

Not fixed yet...

This bug still stands in VirtualBox 4.0.8 and it's very easily reproducible: it happens every time when I first open "Settings" dialog after launching VirtualBox.

The second time (and up) you open the "Settings" dialog it's all good, the bug doesn't get triggered anymore.

Host: Fedora 14 + KDE 4.6.3 + VirtualBox 4.0.8 Guest: Windows XP SP3

comment:17 Changed 10 years ago by frank

This is rather a bug in Qt when running on a KDE system. This bug was fixed but after some Qt update it re-appeared some weeks ago. We are trying to find another workaround but so far without any luck.

comment:18 Changed 10 years ago by ailie

What's the upstream (Qt) bug id ?

comment:19 Changed 10 years ago by frank

Well, I'm not aware of such a bug ID and I didn't submit one just because the testcase is quite difficult to describe.

comment:20 Changed 10 years ago by frank

  • Version changed from VirtualBox 3.2.0 to VirtualBox 4.0.8

I take that back. It's actually a bug in VBox which is triggered by Qt on KDE. Fix will be in the next major release but probably not in the upcoming 4.0.10 yet.

comment:21 Changed 10 years ago by ailie

ok, hardly wait :)

comment:22 Changed 10 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

The fix did it into 4.0.10 which was just released.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use