VirtualBox

Ticket #6727 (closed defect: fixed)

Opened 4 years ago

Last modified 7 months ago

Host Window Manager (GNOME + Metacity) window shortcuts interfering with guest -> fixed in SVN

Reported by: crimsonflame123 Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Configuration: Host - Fedora 12 Guest - WinXP VB - 3.2

When I switch to fullscreen/seamless mode in the guest, then I suppose the correct behavior should be that all the normal keyboard input should be directed to the guest (except 'Right Ctrl' - the host key). In my Window Manager on Fedora 12 (Gnome Metacity), I have plenty of keyboard shortcuts etc. configured for ease. However, these shortcuts should _not_ work when the guest is in full screen mode. Unfortunately they do.

Even Alt+F4 inside a fullscreen guest brings up the "Close VirtualBox" dialog instead of closing the intended app inside the guest. Surprisingly, on enabling compiz, everything works fine. This is a regression since VB 3.1.8 because it worked there.

I do not have a dual monitor setup.

More discussions on this during the BETA feedback process @  http://forums.virtualbox.org/viewtopic.php?f=15&t=30874&sid=3310ef2ed76465abbc47bb7cdcc39695

Attachments

VBox.log Download (46.2 KB) - added by crimsonflame123 4 years ago.
VirtualBox Log File

Change History

Changed 4 years ago by crimsonflame123

VirtualBox Log File

comment:1 Changed 4 years ago by crimsonflame123

Its really a bummer using VB 3.2 in Full Screen mode with this bug. Cant even use Alt+F4 to close windows in my Guests. No workarounds from dev?

comment:2 Changed 4 years ago by poetzsch

  • Summary changed from Host Window Manager (GNOME + Metacity) window shortcuts interfering with guest to Host Window Manager (GNOME + Metacity) window shortcuts interfering with guest -> fixed in SVN

This is fixed in SVN and the fix will be included in the next minor release.

comment:3 Changed 4 years ago by crimsonflame123

Heartening. Thank you so much. I'll wait for the next beta.

comment:4 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:5 Changed 4 years ago by pavel

crimsonflame123, do you observe this fixed in 3.2.2?

Or is this still relevant due to similar #6769?..

comment:6 Changed 4 years ago by frank

Please re-check the updated 3.2.4 build. A fix which might at least restore the old behavior made it into this release. Make sure that you install the latest build (3.2.4-62467).

comment:7 Changed 4 years ago by Mori

  • Status changed from closed to reopened
  • Resolution fixed deleted

I can understand the original reporter, because now I have his problem, only the other way around: it breaks my host shortcuts.

My setup: Two monitors, sawfish as the window manager. There's a Windows guest in fullscreen on Workspace two. No keyboard shortcut conflicts between Windows and sawfish.

Before the last update I could access Windows naturally and integrated into my environment. All I had to know was "Windows is on workspace 2".

Now, before switching to any other workspace i have to check

  • which workspace is active? Is it workspace 2?
    • If no: switch the workspace. Mission accomplished.
    • If yes, is there another window on the second monitor that has the focus?
      • If no: switch the workspace. Mission accomplished.
      • If yes, type host key, then switch workspace

(This could of course be shortened to "look if VirtualBox has the focus", but in reality that doesn't make it easier. Switching workspaces never was something I had to think about before!)

If I make an error, which happens regularly since 1 week, I either open the Windows help or a context menu (Host-key is the menu key). Needless to say, it drives me nuts.

This totally ruined my work flow. I realize that most people have conflicting shortcuts between the host and the guest, but even for them an exception for workspaces would be beneficial. I hope it was OK to reopen this bug for this.

comment:8 Changed 4 years ago by frank

VBox 3.2.6 contains another workaround. How is the state of affairs now?

comment:9 follow-up: ↓ 10 Changed 4 years ago by Mori

My problem seems to be that this bug is fixed, not that it isn't. Sorry, I guess I should have opened a new bug for this after all.

If I understand my problem correctly, I could only use my WM shortcuts because of a (this) bug in VBox. Now that this bug is fixed, I can't use my WM to manage the VBox window anymore.

3.2.6_OSE r63112, GNU/Linux, sawfish

comment:10 in reply to: ↑ 9 Changed 3 years ago by Vincent Bernat

I have the same problem as Mori: I want to be able to keep the shortcuts of my host window manager. I cannot switch to another desktop when VirtualBox has the focus. This is very disturbing. The behaviour of capturing/stealing all keypresses from the window manager should be made configurable.

comment:11 Changed 7 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.18.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use